Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I recently downloaded a program and have now lost Firefox's "awesome bar" which has been replaced by the program's own search bar. How can I restore the "awesome bar" and get rid of the other search bar?

  • 2 replies
  • 7 have this problem
  • Last reply by cor-el

more options

I recently downloaded which then overrode my Firefox "awesome bar". Now when I enter a search item in the search box at the upper right of my screen, I'm automatically shunted to this new search bar where I have to re-enter my search item and click return before it will begin a search. Previously, the Firefox "awesome bar" opened automatically together with my home page and I had the choice of searching using it or the default search box at the upper right of my screen. I 'uninstalled' Bearshare but it now continues to come up when I search using the right hand top search box , forcing me to use it instead of the search box at the upper right of my screen. How do I get rid of it completely so that only the "awesome bar" appears as an extra tab when I open Firefox browser?

All Replies (2)

more options

First, some clarification:

  • The location bar (often called the "awesome bar") is the larger bar on the left that shows you the address of the page you are currently viewing. As you type in the location bar it searches your history and bookmarks for matches.
  • The search bar is the smaller one on the right. It typically displays an icon of whichever search engine is currently selected and may display search suggestions as you type in it.

It sounds like you are referring to the search bar rather than the location bar. You can change search engines for the search bar by clicking on the icon on the left edge of the search bar and choosing a different one. You can also choose "Manage Search Engines" to remove ones you aren't interested in using.

It also sounds like Bearshare might have changed your homepage in Firefox. To restore that you will need to open the preferences menu (click Tools > Preferences), go to the General tab (first on the top left), and click "Restore to Default".

more options

You can also check the Firefox home page setting, default is

See also How to set the home page