Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google ads not showing in blog site. They show in IE.

  • 7 replies
  • 45 have this problem
  • 2373 views
  • Last reply by artloverans

more options

I have a blog site, www.thespecialneedsparent.com. I have the Google ad service. When I look at the site with this browser the ads don't show. When I look at it with IE they do show. They have shown in the past with Firefox. Why are they not showing now? I checked and I do not have the pop-up blocker turned on.

Chosen solution

No problem here. Make sure that you do not have an extension that blocks it.

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

Read this answer in context 👍 2

All Replies (7)

more options

Chosen Solution

No problem here. Make sure that you do not have an extension that blocks it.

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

more options

I went through everything you suggested above and the ads still do not show in Firefox, but show just fine in Internet Explorer. Was there an automatic upgrade by Firefox recently? The ads were showing until recently.

I've done everything suggested here for extensions, themes and plugins and no resolution.

Do you have another suggestion? Are you sure it is not in Firefox itself? The only other possibility I can think of is that I manually ran an AVG virus program today. Is it possible AVG caused a problem?

more options

Reload a web page and bypass the cache with:

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

See Keyboard shortcuts - Perform common Firefox tasks quickly and Use mouse shortcuts to perform common tasks in Firefox

  • "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"
more options

All I had to do was the first step you gave and the ads were back. That seems to have solved it. Thank you.

more options

I don't see my Google AdSense ads at the bottom of my website when I use the Firefox browser, either. But I can see them with the Internet Explorer browser. I hope Mozilla/Firefox might address this compatibility issue with Google AdSense.

more options

I've been waiting for Firefox to fix this, website owners are losing ad revenue, I think they should do away with the ad-block extensions aswell to0 (but require guidelines that site owners half to follow to limit ads to prevent an obscene amount of ads on a page ), but for now I think they should fix this problem or start paying for damages and losses!

Both Firefox 3.6 and Firefox 4 have this problem!

more options

Hello Guys, I had a similar issue where the block of Java Script is missing and also few sections of Google ads were disappearing after loading the pages in Firefox.

Check out this link, how i fixed that Fixing Disappearing Google Ads In Firefox