X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox won't open a PDF link in the browser, screen just shows blank.

Posted

Firefox won't open a PDF link in the browser, when I click on the link the screen just goes to a blank blue screen.

Chosen solution

Please see the Knowledge Base article that details this fix:

https://support.mozilla.org/en-US/kb/pdf-files-are-blank-and-cant-be-downloaded-mac

This issue is caused by the latest version of the Adobe Reader. Even though this plugin has been blocklisted, it looks like people are still reporting this issue. Can anyone still experiencing the issue please post with more information. We need to know if there are other versions of the Adobe Reader causing this issue or if the blocklist is not working.

Read this answer in context 16

Additional System Details

Installed Plug-ins

  • Version 1.7.1.0
  • Shockwave Flash 10.1 r102
  • My Web Search Plugin Stub for 32-bit Windows
  • Cooliris embedded in a tab
  • Google Talk Plugin Video Accelerator version:0.1.43.4
  • Default Plug-in
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.51204.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 GTB7.1 ( .NET CLR 3.5.30729)

More Information

chameau 1 solutions 28 answers

Try to read this article: View PDF files in Firefox without downloading them

Andy 0 solutions 1 answers

Try disabling and re-enabling the Adobe Acrobat plugin.

ritzput 0 solutions 12 answers

I've tried both suggestions above and still when i click on pdf link within a site, it's being blocked and nothing opens. I do not get a blank page, just back to original page. How do i stop this from blocking pdf to open? Same thing happens when i want to view a statement online like at Macy's. Click on link to view statement and now nothing happens since i changed the setting: Tools/Options/Applications and change Adobe to "use Adobe in Firefox" http://support.mozilla.org/en-US/kb/Opening%20PDF%20files%20within%20Firefox

Please adivce???

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

@ritzput -

Are these links supposed to open in a new window (you can compared in a different browser)? If so, perhaps a pop-up blocker is interfering, either the built-in one or one included in a security add-on.

To temporarily disable Firefox's pop-up blocker, you can uncheck the box here:

orange Firefox button or classic Tools menu > Options > Content

ritzput 0 solutions 12 answers

i already have it unchecked. No, if you're on a site and it says click on pdf link, nothing happens. (see attachment). It's being blocked from opening using FF11.0. and did it prior to update. Opens fine in IE9! I'm ready to just give up on FF.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Is the problem only with reading the PDF in the browser? For example if you change the PDF setting to something else, such as "Always Ask", can you open the PDF?

ritzput 0 solutions 12 answers

it's a FFox issue that i wish someone from FFox would answer!

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

@ritzput, this is a user-to-user support forum.

Incidentally, I am running a newer version of the plugin than is shown in your original post.

Your browser reported:
Adobe PDF Plug-In For Firefox and Netscape "9.4.1"

My browser reports:
Adobe PDF Plug-In For Firefox and Netscape 10.1.2

Your browser also reported that you are running Firefox 3.6.13, which is quite out of date. You may want to consider some updates, for security reasons if nothing else. Otherwise, it is difficult to confirm whether your problem still occurs in the versions that board volunteers are using.

Modified by jscher2000

ritzput 0 solutions 12 answers

My FFox is 11.0 and adobe is 10.1.2. I've gone to the plugin checker: http://www.mozilla.org/en-US/plugincheck/ and all is ok. I closed/reopend and the website still not opening PDF. It does open a blank window but then that closes and im back where i started with no pdf opened. I've even tried going to Tools/Options?Content and putting check box next to "Block pop up windows/ Exceptions and added link there and unchecked again.

ritzput 0 solutions 12 answers

I did double check Tools/Options/Content and i have Adobe documents in there twice (see attachment)? Could this be why?

ritzput 0 solutions 12 answers

updating Adobe to 10.1 helped. thank you but still not opening directly.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Regarding multiple entries for PDFs in the Applications list, that is normal. If you float your mouse over a line for a few moments, you can see a different toward the end, e.g., application/pdf and application/x-pdf, reflecting the different content types the server can send for the PDF file.

Regarding the plugin not working, I don't think it's a pop-up window problem since the window does appear, but it's blank.

Can you open Help > Troubleshooting Information and search for any modified preferences that start with dom.ipc? These govern how plugins will be launched (in firefox.exe or plugin-container.exe).

If you don't see any modified preferences, then you probably have the default behavior, which is to launch the Acrobat plugin in plugin-container.exe. You would want to confirm that your security software doesn't block this executable from running and accessing the internet.

seth0913 0 solutions 3 answers

Helpful Reply

Update added by moderator
see PDF files are blank or cause an error message on Mac
and Matt_G (Support Analyst) comment


I have no idea which of these things helped, but I did the tools/options/applications deal and changed "Adobe Acrobat Forms Document" and "Adobe Acrobat XML Data Package files" to "Use Adobe Reader." And I left the "Adobe Acrobat Documents" one with "use Adobe Acrobat (in Firefox)."

I also went into the Mozilla Add-on section under "Tools" and deleted the PDF reader add-on.

I really didn't think anything would work at this point, but after restarting Firefox, it opened the PDF with noooo problem. Amazing.

Thanks for the guidance to get me going on that. It will be so nice being able to skip Explorer entirely. And much less frustrating. Assuming it will continue to work.

Modified by John99

ritzput 0 solutions 12 answers

"Adobe Acrobat Forms Document" set as download and i never looked at this. I switched it as you suggested and now all opens fine. Thanks so MUCH!!!

seth0913 0 solutions 3 answers

Wow. How cool is that? It was a total fluke thing. So glad it helped because I do know how annoying it was. Yay!

Tarada 0 solutions 1 answers

That was really helpful. I disabled Adobe Acrobat in the plugins in add ons and it worked :) Thanks

seth0913 0 solutions 3 answers

Awesome. The other day, after I cleared my cache, it again wouldn't open a PDF. I'm not sure if everything reverted back or what, but I went back and changed things again and it worked fine. So beware.

underwater 0 solutions 2 answers

Helpful Reply

If using a Mac, go to the Firefox Plugins and disable the Adobe Acrobat NPAPI Plug-in, Version 10.1.3. This is a recent plugin update, and as soon as it was installed I noticed that PDFs wouldn't download.

Location: [Menu] Tools/Add-Ons/Plugins

I don't know what other side-effects it can create, but it solved my problem.

Modified by underwater

dani140 0 solutions 1 answers

this was the problem! thanks SO much!

randallina 0 solutions 1 answers

Yes! This worked. THANK YOU!!!