Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't open a PDF link in the browser, screen just shows blank.

  • 37 replies
  • 3495 have this problem
  • 120607 views
  • Last reply by VOCALSpin

more options

Firefox won't open a PDF link in the browser, when I click on the link the screen just goes to a blank blue screen.

Chosen solution

Please see the Knowledge Base article that details this fix:

https://support.mozilla.org/en-US/kb/pdf-files-are-blank-and-cant-be-downloaded-mac

This issue is caused by the latest version of the Adobe Reader. Even though this plugin has been blocklisted, it looks like people are still reporting this issue. Can anyone still experiencing the issue please post with more information. We need to know if there are other versions of the Adobe Reader causing this issue or if the blocklist is not working.

Read this answer in context 👍 16

All Replies (17)

more options

I had the same problem, and the fix above takes care of it by making Firefox treat the PDF link as a download. It works great...

...but before I came to this thread and found the fix, I discovered that even though my PDF link gave me a blank Firefox screen, using "SavePageAs" would save the PDF file just fine anyhow. So the file is there - but it's just not displayed.

more options

Mac 10.6.8 with FF11.0.... I could not view nor download PDF files. ...... My cure - disable plug in named Adobe Acrobat NPAPI Plug-in version 10.1.3........ google and download plug in called PDF browser Plug-in 2.4.4

Modified by kuballi

more options

Everything seems to be fixed by just disabling the adobe acrobat NPAPl version 10.1.3 plug in. Why do I need to download plug in called PDF browser Plug-in 2.4.4?

more options

It seems there is no need to download the pdf browser plug in. I downloaded it first and still could not download pdfs. I then disabled the NPAPI and could down load pdfs. Hence I thought the downloaded plug in was doing the trick. Thanks for pointing out that the problem was actually caused by NPAPI. I should have read your cure first.

more options

You nailed it. Interestingly enough, .pdf files on my Mac (even in FireFox) open in Preview by default; can't imagine why the Adobe plug-in would interfere with that, especially where Adobe is not the default .pdf viewer. Anyone know who we have to pester to have that Adobe Acrobat NPAPI Plug-in fixed?

more options

Thanks so much. You were exactly correct with the issue. Once I disabled Adobe Acrobat NPAPI Plug-in, Version 10.1.3, the browser went to PDF Plugin Browser 2.4.4, which works perfectly. The new Adobe Acrobat Plug-in must block access to PDF Plugin, unless it (Adobe) is disabled. I spent a very frustrating morning fussing with this, then I saw your advice. Many thanks!!!

more options

this was the problem! thanks SO much

more options

I have now had this problem on 2 of my Macs and resolved on both machines. For me Adobe PDF document did not appear in Firefox>Preferences>Applications under Content Type.

I downloaded and installed the latest version of Adobe Reader. Quit Firefox Started Adobe Reader Opened Firefox Adobe PDF document was now listed in the Content Type column Changed Action to Use Adobe Reader (default) All works perfectly.

more options

Disable Adobe reader plugin and take Fox-it reader, free PDF reader, much lighter and more efficient than Adobe !

more options

I have used Firefox as my default browser for years with only a few minor glitches. I am posting here because the current glitch (Firefox won't open (read display) PDF files when I am browsing, is new and happened right after my last Firefox update (around April 26th or so). I believe the update must have had a problem that should be corrected when the brilliant folks who work so hard to make Firefox available to us can work on it. I am so appreciative of the willingness of Mozilla.org to make the internet work for average Joe's like myself and wish them much success in the future.

more options

I did the same (changed the plug in to Adobe Acrobat). Does anyone know where this plug-in came from?

more options

I use FOX IT READER

The program is safe, is much faster and lighter than Adobe Reader and its plugin in Firefox just works !

more options
more options

oh thank you so much ! http://www.kizi1.net

more options

I reinstalled Adobe Reader 9.4 after trying several other options that I read here on the support forum. It works fine now, and I can open pdf files again. I had to go into my preferences under content and change it all back to Adobe Reader 9.

more options

Chosen Solution

Please see the Knowledge Base article that details this fix:

https://support.mozilla.org/en-US/kb/pdf-files-are-blank-and-cant-be-downloaded-mac

This issue is caused by the latest version of the Adobe Reader. Even though this plugin has been blocklisted, it looks like people are still reporting this issue. Can anyone still experiencing the issue please post with more information. We need to know if there are other versions of the Adobe Reader causing this issue or if the blocklist is not working.

Modified by Matt_G

more options

... PDF LINKS NOT WORKING IN FIREFOX? LINKS DONT WORK: PDF : I created a one page PDF (see here) yesterday. It had 8 links going to YouTube, FaceBook, MySpace, SoundCloud, and some others. After uploading it to my Word Press Post Page, and creating the new URL, I logged into GoDaddy to forward the domain "VOCALSpin.com" (with masking) so the long WordPress URL would be hidden.(http://vocalspin.files.wordpress.com/2012/05/vocalspin-music-productions.pdf) This worked great in Chrome! All the links worked! ... In FireFox, only 3 links out of 8 worked. YouTube, Flickr, MySpace & Twitter would not connect! I only got a blank white page, or an error page. In Opera and IE, I got the same failures! BLANK WHITE PAGE or ERROR PAGE. Here's the FIX: After "Masking" the long WordPress URL which ended in ".pdf " with a domain that ended in ".com " ... the -FireFox PDF plug-in- did not distinguish the page as a PDF, so "the built-in PDF Reader" didn't do its job of thoroughly "reading" the document. ... After I removed the "masking," the domain (VOCALSpin.com) then forwarded to the long WordPress URL which showed up in the browser, ending with ".pdf " ... Removing the ".com" ending from the browser, replaced by the URL ending with ".pdf " then caused all the links to work in FireFox, IE, Opera and Safari. ... Chrome was never an issue. In my case, it had to end with .pdf to be truly treated as a PDF! # !Doink! # ... At least- all my links work NOW! HoT-diGGiTy-DawG! ... make sure it ends with .pdf in the browser!

Modified by VOCALSpin

  1. 1
  2. 2