X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I WANT TO REMOVE BABYLON SEARCH WHICH APPEARS WHENEVER I START FIREFOX

Posted

In addition to above I wish to inform you that Babylon addon is not available in my computer so that I may remove the same. I suspect some scam as I want Google as my default web browser & I want that whenever I start Firefox I should see startup page of Firefox and not Babylon search page, Babylon was erroneously downloaded by me which I removed but I am not able to remove Babylon search.


(changed text to lowercase for readability - c)

Modified by cor-el

Chosen solution

To revert to Google as your preferred search engine, please do the following.


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

It's possible that Babylon will add itself to more than one place in about:config. Therefore, after completing the above steps, type "babylon" in the filter at the top. For every instance where you see a setting with that name in it, right click it and choose Modify and then Reset. Then close Firefox and restart it.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.



To reset your home page, do the following.


  • Go to the site you want to set as your homepage.
  • Click the orange Firefox button and go to Options | Options | General (Firefox 4.0.x and above).
  • Go to Tools | Options | General (Previous version of Firefox).
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

Babylon search and toolbar will be installed with an IM chat client called Digsby if you don't opt out of it during the installation. See the info at the foot of this page: http://techshali.com/digsby-instant-messenger-and-email-manager-social-networks/

Read this answer in context 250

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.51204.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Version 1.1.4, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 BTRS26718 Firefox/3.6.13 ( .NET CLR 3.5.30729)

More Information

Xircal 334 solutions 3835 answers

Chosen Solution

To revert to Google as your preferred search engine, please do the following.


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

It's possible that Babylon will add itself to more than one place in about:config. Therefore, after completing the above steps, type "babylon" in the filter at the top. For every instance where you see a setting with that name in it, right click it and choose Modify and then Reset. Then close Firefox and restart it.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.



To reset your home page, do the following.


  • Go to the site you want to set as your homepage.
  • Click the orange Firefox button and go to Options | Options | General (Firefox 4.0.x and above).
  • Go to Tools | Options | General (Previous version of Firefox).
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

Babylon search and toolbar will be installed with an IM chat client called Digsby if you don't opt out of it during the installation. See the info at the foot of this page: http://techshali.com/digsby-instant-messenger-and-email-manager-social-networks/

onetrailspark 0 solutions 1 answers

Helpful Reply

I did this but the problem still persists. The Babylon icon is still on the page and it is still using Babylon as a search engine. I went back into the about:config and when I type in keyword the adjustment suggested is fine but there is another Babylon lineafter it. It is as follows:

extensions.BabylonToolbar.keyWordUrl i user set string http://search.babylon.com/?babsrc=SP_ss&q={searchTerms}&mntrId=a4c2fb5f00000000000000ff9c40d7f0&tlver=1.4.35.10&affID=100489

buena 0 solutions 1 answers

THANKS so much for your post Xircal! It solved my problem! God bless! :D

Modified by buena

SinghPukh 0 solutions 1 answers

Tools>>Add-ons>>Extensions>>Remove Babylon.

ravibora 0 solutions 1 answers

I think many firefox user had the same problem.!

Dawgofwar 0 solutions 2 answers

when you remove it from the. add remove then the program files.go to Mozilla firefox folder in program files open it click search add ons right click on Babylon file delete it.then go to toolbar then options general an change homepage...It dont come back

redmax 0 solutions 1 answers
SOLUTION ::::::::::::::::::::::::::::::::::::::::::

go to: Programs > Run > regedit

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\AboutURLs

in the right side Look for "tabs" right click to modify,in the Value data remove the babylon adress or replace it with your new addresse (it will be your home page )

grayfox5 0 solutions 1 answers

to remove babylon from search in address bar

1- type about:config

2-type babylon in search and hit enter

3-in the given result point to browser.default.searchenginename right click then press on reset the same for search.order

you may want also to remove value babylon.hpon....

ritmanent 0 solutions 1 answers

so thanks very good recommend Xircal

ffxsf 10 solutions 77 answers

If its caused by a virus, heres some free malware scan and removal tools: https://support.mozilla.org/en-US/questions/927290