X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

All the drop down menus in firefox "disappear". I can see the shadow of a drop down menu but there is no text. If I click anywhere in there it will open the webpage or action that is supposed to be in that spot.

Posted

All the drop down menus in firefox "disappear". I can see the shadow of a drop down menu but there is no text. If I click anywhere in the menu it will open the webpage or action that is supposed to be in that spot but I cannot see the menu items.

I saw that someone suggested going to tools then options, etc...but when I open the tools menu there is no text so I do not even know where to click and even when some text appears it is not the full menu. I have tried reinstalling Firefox but this did not help.

Additional System Details

This happened

Every time Firefox opened

Application

  • User Agent:

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
john.surcombe 0 solutions 2 answers

Helpful Reply

I have this problem also with Firefox 4 beta 12 on Windows 7 64-bit. I'm not sure when it started, but I don't recall having this problem when I first installed Firefox 4 (beta 9 I think).

I have two screens, and it only happens when Firefox is rendering the menu in question on the secondary screen. On the main screen it works fine.

I attach a screenshot which shows what the problem looks like - I'd expect Firefox to be displaying the address-bar drop-down, but you only see the drop-shadow.

The drop-down list still operates normally (i.e. you can press the down arrow key, press enter and the site will open). If you move the mouse over the drop-down list, it will appear briefly and then disappear, or flicker on and off repeatedly. The exact behaviour seems to depend on which menu it is.

I tried it in safe mode, and this does make the problem go away. However, it will not work if I start Firefox normally, even if I have disabled all plug-ins and add-ons.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Helpful Reply

This can be a problem with hardware acceleration.

In Firefox 4 Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
john.surcombe 0 solutions 2 answers

cor-el,

Thanks for that. I've disabled hardware acceleration and the problem has gone away.

spod 0 solutions 3 answers

Is there any solution that doesn't require completely disabling hardware acceleration - perhaps just one aspect? Acceleration is a great feature that speeds up browsing, so if there was any way to avoid throwing the baby out with the bathwater...

Grrrrrene 0 solutions 1 answers

Thanks cor-el, that worked for me. At least the problem has disappeared instead of my menus, but this shouldn't be the final solution. As said above: hardware acceleration is kind of nice to have...

Modified by Grrrrrene

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Did you check if there is an update available for your graphics display card driver ?

I do not think that you can fix this by only disabling one specific feature via layers or gfx prefs on the about:config page (Filter: /gfx|layers/).

bluecandy 0 solutions 1 answers

Hi, I have the same problem With Firefox 4 And Windows 7 32 bits. After some tests, Java Console Plugin seems to be the trouble. I disable it and now everything work fine!

slingshotsuicide 0 solutions 1 answers

I can confirm that for some reason Tbird seems to have something to do with it as well, but I've also noticed that when I shift from widget layer to standard (I keep terminator on the widget layer) It causes the problem as well. Changing back and forth doesn't seem to resolve it, but it will cause it to happen. The only thing I've seen work 100% to fix it temporarily is restarting FF4. It's not too practical as I work through firefox and typically have about 20+ tabs open probably 5 with password protected pages in them at any given time. Hope this tidbit helps.

Hasanat 0 solutions 2 answers

How do I go to safe mode? My All programs menu does not show a safe mode menu

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

See:

On Windows you can start in Safe Mode if you hold down Shift and double-click the desktop shortcut or you can use this:

  • Help > Restart with Add-ons Disabled
zaswqqq 0 solutions 1 answers

The hardware acceleration tip appeared to work but was only temporary, like minimizing or restarting. One more reason to look elsewhere for a browser.

412nv 0 solutions 1 answers

This was being caused by Xmarks for me. Disabled that add-on and it now works.