Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

BTYahoo mail, YouTube and Flickr all show messages saying I need to upgrade Firefox but I am using 3.6

  • 4 replies
  • 21 have this problem
  • 45 views
  • Last reply by cicoria

more options

I have installed Firefox 3.6.12 but BTYahoo Mail, YouTube and Flickr all seem to think I'm still using 2.0. In fact, even the form I filled in on this support site says I'm using 2.0!

I have tried uninstalling and re-installing, without removing plugins, extensions etc, but this did not resolve the problem.

Is there some way I can fix this without having to remove all my plugins etc and doing a complete re-install?

Modified by JJP2010

Chosen solution

You need to reset your user agent string (identifies the version of Firefox in use). Your user agent string is:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.10) Gecko/20100914 YFF35 Firefox/2.0 MEGAUPLOAD 1.0 (.NET CLR 3.5.30729)

It is telling other sites that you have Firefox 2.0 . One part of the string is rv:1.9.2.10, that version number indicates that you have Firefox 3.6.10 rather than 3.6.12

To reset your user agent string, follow the instructions in the How to reset the default user agent on Firefox article. Check your Firefox version after resetting the user agent string (in the Help menu select "About Mozilla Firefox"), if it shows Firefox 3.6.10 you will need to update Firefox.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

You need to reset your user agent string (identifies the version of Firefox in use). Your user agent string is:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.10) Gecko/20100914 YFF35 Firefox/2.0 MEGAUPLOAD 1.0 (.NET CLR 3.5.30729)

It is telling other sites that you have Firefox 2.0 . One part of the string is rv:1.9.2.10, that version number indicates that you have Firefox 3.6.10 rather than 3.6.12

To reset your user agent string, follow the instructions in the How to reset the default user agent on Firefox article. Check your Firefox version after resetting the user agent string (in the Help menu select "About Mozilla Firefox"), if it shows Firefox 3.6.10 you will need to update Firefox.

more options

Not to get too emotional about these things, but isn't it great that someone somewhere probably half way round the world from me,can take the time to solve a piddly little problem that I had.

It's fixed now and I'm very grateful! Ta.

more options

You're welcome

more options

Dear Tony,

I wonder if you can help with a similar problem. I have been using Firefox for a long time and never had a problem. Recently I started to experience problems when using BTyahoo mail. It take a long time once opened to access the mails, you click on them and they open as a blank screen. Finally after a while I can read them, but is very annoying. I have spoken with BT and they say is a browser problem. I have re-installed firefox, reset the profiles and else as instructed in trouble shooting, but it hasn't changed. Also when I close a strange window pops up saying "sorry we cannot access your contacts". Yesterday I got this when trying to open mail btyahoo: The error, LaunchFFC-1 , occurred when trying to connect to BT Yahoo! Mail.

Can you advice what might be wrong and how to solve it?

Many thanks

Modified by cicoria