X
Tap here to go to the mobile version of the site.

Support Forum

The buttons on my google toolbar have disappeared on home page. I've been into preferences/buttons and there are none to check. where are they?

Posted

I have Firefox 3.6.12 on the new Macbook. The buttons on the google toolbar have disappeared though the space is there for them. I have checked View>Toolbars>google toolbar. I have been Firefox>preferences>extensions>Google toolbar>preferences>buttons and there are none there to check or to add. I have uninstalled and installed. It makes no difference. Where have they gone? How do I get them back?

I have Firefox 3.6.12 on the new Macbook. The buttons on the google toolbar have disappeared though the space is there for them. I have checked View>Toolbars>google toolbar. I have been Firefox>preferences>extensions>Google toolbar>preferences>buttons and there are none there to check or to add. I have uninstalled and installed. It makes no difference. Where have they gone? How do I get them back?

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • RealPlayer Plugin
  • 3.0.40818.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r85

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 GTB7.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12006 solutions 111552 answers
  • "Clear the Cache": Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites that cause problems: Firefox > Preferences > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

* "Clear the Cache": Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now" * "Remove the Cookies" from sites that cause problems: Firefox > Preferences > Privacy > Cookies: "Show Cookies" Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). * Don't make any changes on the Safe mode start window. See [[Troubleshooting extensions and themes]] and [[Troubleshooting plugins]]

Question owner

Thanks very much. I did all that. I cleared the cache. I removed cookies. I disabled all add-ons. No change. So I uninstalled and re-installed Google toolbar. Still no buttons - just the grey space where the bar should be. And still no buttons appear in the box when I go into Firefox>preferences>manage add-ons>preferences>buttons. I'm an amateur at this so I'd welcome other thoughts

Thanks very much. I did all that. I cleared the cache. I removed cookies. I disabled all add-ons. No change. So I uninstalled and re-installed Google toolbar. Still no buttons - just the grey space where the bar should be. And still no buttons appear in the box when I go into Firefox>preferences>manage add-ons>preferences>buttons. I'm an amateur at this so I'd welcome other thoughts
RapidanBear 0 solutions 2 answers

I have the exact same problem with Firefox 3.6.12 in Windows XP.

My wife has Windows 7, and this problem did not occur for her.

I will follow with interest your dilemma and the suggested solutions (if any).

I have the exact same problem with Firefox 3.6.12 in Windows XP. My wife has Windows 7, and this problem did not occur for her. I will follow with interest your dilemma and the suggested solutions (if any).
cor-el
  • Top 10 Contributor
  • Moderator
12006 solutions 111552 answers

You can try "Reset all user preferences to Firefox defaults" on the Troubleshoot Firefox issues using Safe Mode start window.


Create a new profile as a test to check if your current profile is causing the problems.
See Basic Troubleshooting: Make a new profile

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)
See http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

You can try "Reset all user preferences to Firefox defaults" on the [[Safe mode]] start window. ---- Create a new profile as a test to check if your current profile is causing the problems.<br /> See [[Basic Troubleshooting#Make_a_new_profile|Basic Troubleshooting&#58; Make a new profile]]<br /> There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"<br /> If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)<br /> See http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
oceanbabi 0 solutions 2 answers

Thanks, cor-el! :-D Making a new profile, copying over only the bare necessities from the old profile to the new and deleting the old profile worked! Only took about 20mins, which is nothing compared to the amount of time I have spent the past few days troubleshooting and searching forums all over the inter-webs. Thank you, thank you! Woohoo! :-D

Thanks, cor-el! :-D Making a new profile, copying over only the bare necessities from the old profile to the new and deleting the old profile worked! Only took about 20mins, which is nothing compared to the amount of time I have spent the past few days troubleshooting and searching forums all over the inter-webs. Thank you, thank you! Woohoo! :-D

Question owner

Cor-el Thanks again. But when I tried to open the Profile Manager through the Terminal box - there's nothing. It says there's no such file. So I couldn't even get to the first step!

Cor-el Thanks again. But when I tried to open the Profile Manager through the Terminal box - there's nothing. It says there's no such file. So I couldn't even get to the first step!

Question owner

I tried again and got there. But when I created a new profile all my default profile was copied across into it. And that opened a second background copy of Firefox. Which meant I couldn't open Firefox at all. Which meant I had to delete the new profile. I think I must be very hamfisted at this. Is there an easy way? Or is it best just to give up.....

I tried again and got there. But when I created a new profile all my default profile was copied across into it. And that opened a second background copy of Firefox. Which meant I couldn't open Firefox at all. Which meant I had to delete the new profile. I think I must be very hamfisted at this. Is there an easy way? Or is it best just to give up.....
RapidanBear 0 solutions 2 answers

Helpful Reply

I tried making a new profile, but when I installed Google toolbar on the clean profile, the toolbar did not show up and was not on the list of available toolbars. It seemed like a good idea, but not for me. (Windows XP)

I tried making a new profile, but when I installed Google toolbar on the clean profile, the toolbar did not show up and was not on the list of available toolbars. It seemed like a good idea, but not for me. (Windows XP)
beo2nice 0 solutions 1 answers

Helpful Reply

Hi just solved the issue by deactivating all add-ons named "java console" (all of them whatever the version number). Google toolbar is now OK for me

:o)
Hi just solved the issue by deactivating all add-ons named "java console" (all of them whatever the version number). Google toolbar is now OK for me :o)

Modified by beo2nice

n7tek 0 solutions 1 answers

Apparently Java Console is no longer supported (it doesn't work with Sun Java) so uninstall it and your Google Toolbar buttons should come back. In researching this I also found out that one should probably disable (or uninstall) the Java Quick Starter. Apparently it makes you vulnerable to a worm that will cause the Firefox browser to be redirected to sites that you didn't request.

Apparently Java Console is no longer supported (it doesn't work with Sun Java) so uninstall it and your Google Toolbar buttons should come back. In researching this I also found out that one should probably disable (or uninstall) the Java Quick Starter. Apparently it makes you vulnerable to a worm that will cause the Firefox browser to be redirected to sites that you didn't request.