Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why does my firefox close all my tabs when I close the browser?


On my new (other) computer, since I got it recently I got a message from Firefox about an update and I loaded it. Since then when I close the browser, it automatically closes all my tabs and does not even ask me if that is OK like it used to. Is there a fix for this or can I go back to my previous version somehow? I believe it is running the 3.6.12 now, but not certain and I don't know which version I had just before this update. The computer having this problem is a new Acer PC running 64bit windows 7 and Microsoft 2010 software

Additional System Details

This happened

Every time Firefox opened

This started when...

I downloaded and began using the newest version of firefox 3.6.12 I think

Installed Plug-ins

  • np-mswmp
  • Winamp Application Detector
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.1 r102
  • iTunes Detector Plug-in
  • 4.0.50917.0
  • MSN® Toolbar
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications


  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20101026 Firefox/3.6.12

More Information

DaveRo 18 solutions 175 answers

type about:config
enter 'close' into filter
find browser.tabs.warnOnClose
if it's false double-click it to make it true

  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

You can also check the startup setting.

In Firefox 3 you do not get the 'Save & Quit' pop-up dialog if Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time" is selected.

To get the 'Save & Quit' pop-up dialog you have to select one of the other choices (Show my home page, Show a blank page).

Question owner

cor-el, I know it says the problem is solved, and I did indicate that it was helpful. At least with your suggestions I knew what to do, but the other reply was greek to me. At any rate, I did exactly what you said to do, but all is the same-no change. I have NO idea what to do now. Do you have any other comments on this issue? Thanks for the help, Steven

DaveRo 18 solutions 175 answers

Sorry it was Greek - it's hard to know how experienced questioners are..

You type about:config into the address bar - where the web address goes. Accept the 'be careful' warning. You'll see all the hidden options or preferences Firefox has.

By typing stuff into the 'filter' box you can select to see some of them. Type 'close' into that box and you should see all the options with 'close' in them.

Look for the one called browser.tabs.warnOnClose It specifies whether to give you a warning when you close the browser (I think). If the value is false you need to change it to true. Do that by double-clicking on that line (or right click and modify).

Close that tab and see if it works.

(That setting is usually the result of a 'Don't tell me again' box - probably clicked accidentally.).

Question owner

Sorry it took me so long to respond to this. I did exactly as you described and still it doesn't work. I am totally confused, esp not being much of a techie. Any other suggestions?

  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Helpful Reply

Did you check the startup setting in Tools > Options > General > Startup: "When Firefox Starts" ?

Question owner

Yes, I did it exactly as you described, and still it doesn't work. I even changed it in the box to "show my home page" and tried that- same thing, except it did ask if I wanted it to save my tabs. So then I put it back as it was and tried again, still didn't work. I am really baffled now:(

hblh20 0 solutions 1 answers

Mine says "true" but it still isn't warning me before closing. My mouse is glitchy, and closes my browser often, interrupting any work that I do, and causing me to start over. Is there anything else I can do?