X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Trouble importing IE favorites

Posted

The Import button under the File tab isn't live so I can't click it. Because of that, I can't import my Internet Explorer Favorites to Firefox. Why isn't my Import button live?

When I first loaded Firefox onto my computer, some of my IE Favorites were automatically copied to Firefox, but not all of them. I'm now trying to copy the rest of them to FF. What do I do?

And, yes, I read through the help section of FF and found the instructions to copy IE Favorites to FF, but being able to do the copy requires that the Import button be live.

Chosen solution

In IE:
File > Import/Export - Export to HTML file

then in Firefox:
Bookmarks > Organize Bookmarks -> Import & Backup - Import HTML... = From HTML file

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • iTunes Detector Plug-in
  • DivX Web Player version 2.0.3.4
  • GEPlugin
  • 4.0.50917.0
  • NPWLPG
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Google Update
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24405 answers

Chosen Solution

In IE:
File > Import/Export - Export to HTML file

then in Firefox:
Bookmarks > Organize Bookmarks -> Import & Backup - Import HTML... = From HTML file

Question owner

Sorry to be a bit on the not highly computer literate side, but I'm having a bit of trouble with the "Export to HTML file" part of that. I go through the export process on IE but become stuck when it wants me to choose a file to export my Bookmarks to. The real problem is that I don't understand what you mean by "Export to HTML file."

Thanks for any further help.

Question owner

Never mind. I think I figured it out. Sometimes the gears work slowly, but I'm there now. Thank you very much.

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24405 answers

You're welcome.

dsraup 0 solutions 1 answers

I had a lot of trouble finding this in IE 8...Here's where to get started on this fix within IE....From Windows Help and Support...

To export favorites from Internet Explorer 8

Follow these steps on the computer that you're exporting your favorites from.

Click to open Internet Explorer.

Click the Favorites button, click the arrow next to the Add to Favorites button, and then click Import and Export.

In the Import/Export Settings dialog box, click Export to a file, and then click Next.

Select the Favorites check box, and then click Next.

Select the folder that you want to export your favorites from, and then click Next.

By default, Internet Explorer creates a file called bookmark.htm in your Documents folder. If you want to use a name other than bookmark.htm or to store the exported favorites in a folder other than Documents, specify the new file and folder name.

Click Export. If you already have a file by the same name, Internet Explorer will ask you to replace it. Click Yes if you want replace the file or click No and type a new file name.

Click Finish.

Note If the folder you select cannot be written to, such as another user's Documents folder, the export will fail. Retry the export with another folder.

tlaingworth 0 solutions 3 answers

Not working on my computer. Tried importing from Internet Explorer using that feature; didn't work. Then saved IE bookmarks to htm file, and tried import from there; also didn't work. What gives?

tlaingworth 0 solutions 3 answers

Is there anything in settings on Firefox that would prohibit IE bookmarks from being imported?

Modified by tlaingworth

tlaingworth 0 solutions 3 answers

P.S. I saved the htm file to my desktop, not my documents file.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Make sure that the file has a .html file extension. You can see that if you open the Properties via the right-click context menu. You can also try to open the in a Firefox tab via File > Open File to see if that works. It is possible that you have links or description in your favorites that are not in Unicode and that are causing problems. So you may need to check the file for that in a text editor.

sparky4511 0 solutions 1 answers

I am using 4.01 and my import tab is not working. I had to go to bookmarks tab, then show all bookmarks, then I used the import and backup tab to import from IE.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

If File> Import is grayed then check that you aren't running Firefox in permanent Private Browsing mode.