X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

What is Firefox Setup 3.6.10(2).exe and is it necessary?

Posted

What is the function of Firefox Setup 3.6.10(2).exe and is it necessary?

When I logged into Windows Live Hotmail today, I received a message to upgrade my Firefox browser by installing this programme. I am unable to find out any information about it on the Mozilla website.

I have downloaded to file, but am hesitant about installing it until I know more about it.

Additional System Details

This happened

Just once or twice

This started when...

Today 5 September 2010

Installed Plug-ins

  • Google Gadget Plugin 5.7.712.19360
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • iTunes Detector Plug-in
  • GEPlugin
  • 4.0.50524.0
  • Office Live Update v1.3
  • NPWLPG
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Next Generation Java Plug-in 1.6.0_16 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 GTB7.1

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

That probably means you downloaded the setup file twice. The setup file is called Firefox Setup 3.6.10.exe, but if this file already exists, a second one called Firefox Setup 3.6.10(2).exe will be created.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Your above posted system details show outdated plugin(s) with known security and stability risks.

  • Next Generation Java Plug-in 1.6.0_16 for Mozilla browsers

Update the Java plugin to the latest version.