X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox (mozilla.org ) ftp server

Posted

I am trying to download firefox 3.6.10 from the ftp server (yes, i know that 3.6.12 is available, but i need 3.6.10 to resolve a plugin issue).

For some reason, I cannot start the "Firefox Setup 3.6.10.exe" download from "ftp://ftp.mozilla.org/pub/firefox/releases/3.6.10/win32/en-US/". I think the file is missing on the ftp server?

Thanks

Chosen solution

I get a 550 Permission denied. when I tried to download 3.6.10. Couldn't find it on any of the download mirror, websites either; most mirror's only show 3.6.11 and 3.6.12, and the one I found that has a 3.6.10 folder - the folder is empty.

You're gonna have to locate that version on a non-Mozilla website.

This probably the safest choice - http://www.oldapps.com/firefox.php - Old Apps is an official Mozilla mirror, but that part of the Old Apps website is not part of the Mozilla "mirror".

Read this answer in context 3

Additional System Details

This happened

Every time Firefox opened

This started when...

today

Installed Plug-ins

  • Shockwave Flash 10.1 r102
  • Adobe Acrobat Plug-In Version 6.00 for Netscape
  • Office Plugin for Netscape Navigator
  • Default Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • 4.0.50917.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

"ftp://ftp.mozilla.org/pub/firefox/releases/3.6.10/win32/en-US/Firefox%20Setup%203.6.10.exe"

the-edmeister
  • Top 10 Contributor
  • Moderator
3194 solutions 24384 answers

Chosen Solution

I get a 550 Permission denied. when I tried to download 3.6.10. Couldn't find it on any of the download mirror, websites either; most mirror's only show 3.6.11 and 3.6.12, and the one I found that has a 3.6.10 folder - the folder is empty.

You're gonna have to locate that version on a non-Mozilla website.

This probably the safest choice - http://www.oldapps.com/firefox.php - Old Apps is an official Mozilla mirror, but that part of the Old Apps website is not part of the Mozilla "mirror".

Question owner

Thanks for the help. The www.oldapps.com version is perfect as it matches the MD5 posted on the official ftp mirror. I notified the webmaster about the 550. Again, thank you.