X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox stays as active process after being closed as application

Posted

i close Firefox with "file - exit", and when i try to start a new session, i got a message. Firefow is still running as active process. I have to open task manager and close the process "Firefox.exe*32"

Additional System Details

This happened

A few times a week

This started when...

i got firefox 3.6

Installed Plug-ins

  • Anti-Leech Plug-in v.1.0.2.4
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.1 r82
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Plugin NPAPI Ma-Config.com
  • 4.0.50826.0
  • NPWLPG
  • Version 1.1.4, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 GTB7.1

More Information

Helper7677 165 solutions 1653 answers

Helpful Reply

Firefox not closing completely (hanging at exit) is frequently caused by an extension or a plug-in.



You need to update your plugins. It is important to keep them updated due to continuing security fixes and improvements in those plug-ins:

  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
    • NOTE: A new security update for Adobe Reader 9.3.4 is due to be released 2010-10-05
  2. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
      • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below
      • On the Adobe page, un-check any extra items (i.e. Free McAfee® Security Scan Plus) then click Download button
      • If you see message just under tabs, DO NOT click the Allow button, instead click below that where it says "click here to download".
      • Click "Save to File"; save to your Desktop (so you can find it)
      • After download completes, close Firefox
      • Click the installer you just downloaded and allow the install to continue
        • Note: Vista and Win7 users may need to right-click the installer and choose "Run as Administrator"
      • Download link and more information: https://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader
    • After the installation, start Firefox and check your version again.

Modified by Helper7677

remiller9 0 solutions 3 answers

I thank all of those who sent in suggestions (I would have gotten back to you sooner but life and some emergency surgery got in my way.). I will try sthese possible solutions and write a reply again afterwards. Thanks again.

P.S. I discovered earlier today that while having Windows Task Manager open I tried to open Firefox twice, Thunderbird once and Internet Explorer twice and the result of all 5 tries opened the 'Firefox.exe *32' file (twice), the Thunderbird.exe *32 (once) and the iexplore.exe files in Processes but did not opn those programs in Applications?? I had to restart my pc (an excruciatingly slow process) before I could actually open Firefox and get to these helpful pages.

Winchester 0 solutions 1 answers

Helpful Reply

I was having this same problem with both firefox.exe and iexplore.exe. It turns out that it was the Skype Click to Call plugin/addon was the problem. Everything worked fine once I uninstalled it.

wxwizard 0 solutions 1 answers

@ winchesterlyon. Thanks! That did the trick!

It was a bit of a painful process as I was kind of in an infinite loop with the stuck firefox.exe*32 process. What worked was starting firefox in safe mode (hold down shift key and click firefox launcher) and select "Disable all add-ons" and "Make Changes and Restart". Then in the restarted firefox, go to the add-ons and disable Skype click to call. Hope help others...