Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox 3.6.9 will not upload photos to Blackboard 8 Academic Suite, Blackboard's solution is to use Firefox 2.0.0.20 I need to use a more recent version of firefox. Any ideas?

more options

I have windows 7 professional. My son is taking an online class (digital photography) which uses Blackboard 8 Academic Suite. Last week photos stopped uploading successfully. Blackboard's solution is to use Firefox 2.0.0.20. I had to uninstall Firfoz 3.6.9, and install the earlier version from a link provided by Blackboard. It worked, however Firefox popped up a message saying that this version is no longer supported and that I should update to 3.6

All Replies (1)

more options

Depending upon which version of WebCT your school is using, you will have to use Firefox 3.5.x, Firefox 3.0.x, or Firefox 2.0.0.20 when accessing the Blackboard site.

My advice is to install the Firefox Portable version that you need for Blackboard on your computer, and use that installation only for Blackboard. Continue to use 3.6 for all other web browsing. FP 3.5.8 is here: http://portableapps.com/apps/internet/firefox_portable/localization#legacy FP 3.0.18 is here: http://portableapps.com/apps/internet/firefox_portable/localization#legacy FP 2.0.0.20 is here: Firefox, P.E. Legacy/Firefox_Portable_2.0.0.20_en-us.paf.exe