Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox only types numbers instead of letters

  • 10 replies
  • 90 have this problem
  • 977 views
  • Last reply by MonikaR

more options

Hello.

My problem is that I can't type english in firefox anymore.

What happens is whenever I type, sometime english will be typed as it should, but then every typing keys start to type numbers only, from 0 through 9 in continuous interval. I think it triggers whenever i hit right shift, but I'm not sure yet.

I wrote this on notepad and copied and pasted on the details section.

I got this problem yesterday, 8/12/2010 and couldn't figure out how to fix it.

I tried to reinstall firefox, which didn't help.

I think its virus of some type, but antivirus isn't picking up any. The only new website I've been to and stayed for long time is called www.mangareader.net.

I don't have recovery option saved nor have a cd to reinstall.

How can I solve this problem?

Modified by NoahSUMO

All Replies (10)

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).
See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.
You can use "Disable all add-ons" on the Diagnose Firefox issues using Troubleshoot Mode start window to disable all extensions.
You have to close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

more options

It isn't extensions. I even disabled all the plugins but Firefox still typed in numbers.

more options

I am having the SAME problem. It was so hard to find a help that didn't think this was Number Lock (when I searched for an answer). It happens even when I type A, and if I type A three times, it will be a different number each time. It goes 0-9 and if you hit shift, it will do the correct punctuation for that number, then go to the next.

Example: Apples Are Good --> !23456 &89 )123

Letters that are not impacted by number lock are impacted, number lock is NOT on, and it does punctuational stuff too. No signs of a virus or anything either. Well, no OTHER signs. Strangest thing ever... But I don't think it is completely restricted to Firefox. Although stuff like Word has NO problems even when Firefox does.

It also isn't perpetual, but it is re-occurring.

THANKS!

more options

I had this problem, and so I brought up IE and had the same problem. I plugged in an external, USB keyboard. The USB keyboard worked properly, and so did the PC keyboard. This may be a keyboard driver problem with Lenovo laptops? Maybe we can tie this to an OS/HW combination? I also noticed this mostly with Flash player.

more options

I replied to the lenovo forums regarding a fix (or workaround) for this problem. In my case, it happened out-of-the-box for my G555 both in Firefox and IE URL address fields.

If your running GuardID that could be the problem. Further info in http://www.guardedid.com/support_faq.aspx confirms this as the program that is intercepting the keystrokes and converting them to numbers in sequence.

I noted this problem didn't exist if I started my computer in safe mode. Both Internet Explorer and Firefox URL address fields worked fine. But if I started my computer in normal mode, typing letters in the URL field for either browser would result in a counting sequence of numeric digits. So, I began removing startup programs one by one (by unchecking via Control Panel/System and Security/Administrative Tools/System Configuration Startup tab). When I unchecked the following (and rebooted), the problem went away:

Startup Item: GID Desktop Application

Manufacturer: StrikeForce Technologies Inc.

Command:C:\Program Files\SFT\GuardedID\gidd.exe /

more options

You're right on the money ... that app is part of the Comcast security Suite LOL drove me nutz to the point of formatting otherwise healthy system. I switch from my ol trusty Kaspersky Internet Security to ''Free'' Norton junk (part of Comcast Security) and had a ball with my PC until I've done clean install and problems reoccurred. That's what I get for being El Cheapo! Needless to say I've purchased another license from Kaspersky and am Very Happy with my PC. I've built this machine so I know how it breaths.

more options

i am also having this strange key board problem . i never even noticed that there were alternative characters on those center keys ( 7,u,j,m.8.i.k etc) 4ntil this problem occured. it is going to be hell typing any kind of document with this problem.

anyway, i dont have the program GuardID, so what do i do???
more options

Thank you so much for posting a fix to this problem. I'm one of those technology-challenged people, and I appreciate you including step-by-step instructions to correct this problem. This "letters becoming numbers" problem could have really messed up my day, and I appreciate you helping all of us solve this issue with such clear, specific directions.

more options

This worked, many thanks!!!

more options

I have been having this same issue to of late...and its occasional. Like right now, Im typing just fine but it could change at any moment. I have an Acer laptop that this is happening on. I have to do a restart of my system in order to fix it until the next time it pops up. It would be nice to know what is actually causing it so I can get it fixed. Is it a add-on, program, update, or what that is causing this? It is becoming very annoying and want it to stop. Any ideas?