X
Tap here to go to the mobile version of the site.

Support Forum

Can’t access SSL site in Firefox.

Posted

A am attempting to access a Cisco server with a self-signed certificate. I can access it in MSIE.

When I try to access the server, I get the Firefox error “This Connection is Untrusted”.

I choose the option to “Add Exception”.

The following dialog box says; “Valid Certificate. There is no need to add an exception”, and does not give me the ability to “Confirm Security Exception” like it normally would. My only option is to “cancel” and go back to the previous error “This Connection is Untrusted”.

How do I get Firefox to allow me to access this web server?


URL of affected sites

http:// private

A am attempting to access a Cisco server with a self-signed certificate. I can access it in MSIE. When I try to access the server, I get the Firefox error “This Connection is Untrusted”. I choose the option to “Add Exception”. The following dialog box says; “Valid Certificate. There is no need to add an exception”, and does not give me the ability to “Confirm Security Exception” like it normally would. My only option is to “cancel” and go back to the previous error “This Connection is Untrusted”. How do I get Firefox to allow me to access this web server? == URL of affected sites == http:// private

Additional System Details

Installed Plug-ins

  • -IE Tab Plug-in for Mozilla/Firefox
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.2
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.732
  • ActiveTouch General Plugin Container Version 105
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Office Plugin for Netscape Navigator
  • Shockwave Flash 10.1 r53
  • 4.0.50524.0
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Java Plug-in 1.4.2_04 for Netscape Navigator (DLL Helper)
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.3
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.11) Gecko/20100701 Firefox/3.5.11 ( .NET CLR 3.5.30729)

More Information

NA

waid 0 solutions 1 answers

Yes! This is exactly my problem today. I keep getting "This Connection is Untrusted" for a server with a "wrong domain" certificate. (We're using https to get SSL encryption, not authentication.)

Normally, I click "I understand the risks" and tell it to "permanently store this exception", and it lets me through, at least for an hour.

Long-term problem: I've done this about two hundred times over the last several years, and it *still* coughs up this warning about one out of three attempts. (Yes, the system time is correct on my laptop. No, I don't do anything complicated about restoring settings or deleting cookies or anything like that.) I need a "really, really, REALLY permanently store this exception" button, not the "maybe sometimes store this exception for a while" button.

Today's problem:

I'm trying to get to foo.bar.com.

It chokes on an "untrusted" certificate, claiming that the certificate is valid only for www.bar.com. When I click it reloads the certificate and says... "This site provides valid, verified information"... to baz.bar.com.

Okay, so let's reload the page... and I'm back to "This Connection is Untrusted" — it's unhappy about the www.bar.com certificate again.

Seriously, I've done this cycle more than a dozen times in the last hour. How the heck do I get it to let me through to my server? And in the bigger picture, will we ever have a setting that says, "When going to foo.bar.com, just use SSL and do not even ask for the bleeping certificate"?

Yes! This is exactly my problem today. I keep getting "This Connection is Untrusted" for a server with a "wrong domain" certificate. (We're using https to get SSL encryption, not authentication.) Normally, I click "I understand the risks" and tell it to "permanently store this exception", and it lets me through, at least for an hour. Long-term problem: I've done this about two hundred times over the last several years, and it *still* coughs up this warning about one out of three attempts. (Yes, the system time is correct on my laptop. No, I don't do anything complicated about restoring settings or deleting cookies or anything like that.) I need a "really, really, REALLY permanently store this exception" button, not the "maybe sometimes store this exception for a while" button. Today's problem: I'm trying to get to foo.bar.com. It chokes on an "untrusted" certificate, claiming that the certificate is valid only for www.bar.com. When I click it reloads the certificate and says... "This site provides valid, verified information"... to baz.bar.com. Okay, so let's reload the page... and I'm back to "This Connection is Untrusted" — it's unhappy about the www.bar.com certificate again. Seriously, I've done this cycle more than a dozen times in the last hour. How the heck do I get it to let me through to my server? And in the bigger picture, will we ever have a setting that says, "When going to foo.bar.com, just use SSL and do not even ask for the bleeping certificate"?
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156717 answers
See http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/application_networking_manager/4.1/virtual/appliance/guide/VA_setup.html