X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I've lost the File, Edit, Tools, Options etc from the top of my browser window. How do I fix this?

Posted

At the top of my browser page I used to have File, Edit, Tools, Options, Help etc. well that has vanished. How do I get them back?

This happened

Every time Firefox opened

== not sure when, but after an update, I think.

Chosen solution

In Firefox 3.6 and later on Windows you can hide the menu bar via "View > Toolbars" or via the right click context menu on a toolbar. Press F10 or press and hold the Alt key down to bring up the menu bar temporarily. Go to "View > Toolbars" or right-click the menu bar or press Alt+V T to select which toolbars to show or hide (click on an entry to toggle the state).

See also What happened to the File, Edit, and View menus? and http://kb.mozillazine.org/Toolbar_customization

Read this answer in context 21

Additional System Details

Installed Plug-ins

  • -nphpclipbook
  • npmnqmp 989898989877
  • ScorchPlugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 6.0.12.775
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • 4.0.50524.0
  • NPWLPG
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Reader Library Helper Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_14 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722 YFF35 Firefox/3.6.8 GTB7.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96854 answers

Chosen Solution

In Firefox 3.6 and later on Windows you can hide the menu bar via "View > Toolbars" or via the right click context menu on a toolbar. Press F10 or press and hold the Alt key down to bring up the menu bar temporarily. Go to "View > Toolbars" or right-click the menu bar or press Alt+V T to select which toolbars to show or hide (click on an entry to toggle the state).

See also What happened to the File, Edit, and View menus? and http://kb.mozillazine.org/Toolbar_customization

cr1441 0 solutions 1 answers

I have tried all those things, plus uninstalling, reinstalling and nothing works. Firefox is not functional for me; currently I am using explorer. I've had two other computer geeks tried to figure this one out and have gotten no where. Other than trying the Alt V or Alt V T M method, what else is there?

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96854 answers

Create a new profile as a test to check if your current profile is causing the problems
See Troubleshoot and diagnose Firefox problems (under Make a new profile)
There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"
If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)
See http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

See also http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Extension_issues

Modified by AliceWyman

kurvkat 0 solutions 1 answers

Helpful Reply

i pressed F10 then the prob was ok - i then went into the view option and toolbars where my menu bar had been un clicked problem solved :-)

chopin 0 solutions 1 answers

Many thanks.After trying so many different things it seems so easy that it was as simple as pressing F10.Saved me a trip to the serviceman.

kahuna07 0 solutions 4 answers

Sorry, folks.

I've given up. I am no longer using Firefox because it is so tedious to fight with it. Browser items at the top (tools) should never have been "removed". After at least 10 or more years with Mozilla and its Fire Fox browser, ...I am just no longer using Fire Fox. I am back with the more reliable Internet Explorer. This should not require fixing you damn fools. Adios Mozilla. You seem to have over reached. I guess if I wanted tedium I should have gone to Linux but I think they are less tedious than this stupid set up.

radrodder04 0 solutions 1 answers

Thanks I pressed the F10 key went to view and checked menu bar THANKS A MILLION I wonder why keyboards don't have a check mark????