Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When trying to watch videos on YouTube and other sites the video screen is completely green.

  • 3 replies
  • 197 have this problem
  • 35475 views
  • Last reply by maxplouf

more options

When trying to watch videos on various websites including YouTube, the video screen is completely green. I can hear the audio, but no visual. This does not happen with every video, but it is fairly common for me. When I try to watch the same videos with Internet Explorer they work fine. Anyone have any ideas? Thanks in advance!

This happened

Every time Firefox opened

== Last week

Chosen solution

Try to disable the hardware acceleration in the Flash Player.

Flash "Display settings" window: http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html

Read this answer in context 👍 21

All Replies (3)

more options

Chosen Solution

Try to disable the hardware acceleration in the Flash Player.

Flash "Display settings" window: http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html

more options

I had a different problem, I was getting video driver errors constantly when watching videos, but only on YouTube. I changed this setting and it fixed it. But I had to go to another site that had flash videos to do it, when I tried it on YouTube (1) my driver kept crashing and (2) 'Settings' on the right-click menu was GRAYED OUT and couldn't be clicked.

This problem was really getting annoying and all the other things I tried didn't work. I also posted my problem here a couple of days ago but now I can't find it, and have no idea what happened to it. It's really hard to find what you need here.

more options

Hi,

I am having a pb similar to Capain Jeff but with internet explorer. On a website to watch news with video streaming, after the ads are displayed the flash player bugs and the browser stopps and the screen goes grey if i keep clicking.

I had he same green screen on youtube but fixed it thanks to the 1st post from cor-el.

thanks