Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I turn on WebGL in Firefox 4 Beta?


Hi - how do I turn on WebGL in the new Firefox4 Beta? thanks Nic

This happened

Every time Firefox opened

Chosen solution

as can be found in this article:

- Type “about:config” in your browser’s URL bar - Do a search for “webgl” in the Filter field - Double-click the “enabled_for_all_sites” preference to change it to “true”

that should do it...

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • -http://www.facebook.com/fbplugin/
  • iPhoto6
  • RealPlayer Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Browser Plug-In: Plays DivX video in your browser!
  • O3D Plugin version:
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Java Plug-In 2 for NPAPI Browsers
  • Unity Web Player lets you experience dazzling interactive 3D right in your browser. For more information, visit Unity .
  • 4.0.50401.0
  • ShiVa3D Plugin 1,8,1,0 for 3D real-time applications made with ShiVa Editor.
  • Shockwave Flash 10.0 r45
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.


  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

More Information

raptorninja 0 solutions 1 answers

works perfect on ubuntu 11.10 with nvidia 9400 read: "How to force-enable blocked graphics features" https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#How_to_force-enable_blocked_graphics_features

and visit : http://webglsamples.googlecode.com/hg/field/field.html