Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After update to Quantum 60.0.1 pages with WebGL (tinkercad.com) doesn't work. Any help?

  • 8 replies
  • 1 has this problem
  • 44 views
  • Last reply by magy357

more options

After update to Quantum 60.0.1 pages with WebGL (tinkercad.com) doesn't work. I could not find anywhere on internet, how to enable or turn it on. Only something like this for older version:

"To enable WebGL, set webgl.force-enabled to true." Ok, but set how??? Where? Any help?

Attached screenshots

Modified by magy357

All Replies (8)

more options

What kinda JS API are you using? WebGL is javascript from what I can find.

more options

WestEnd said

What kinda JS API are you using? WebGL is javascript from what I can find.

Speak with language I can understand :D WTH is JS API? I just update Mozilla Firefox because getting message I have to, and after that suddenly this page doesn't work. It's website, where you can made 3D design easily. I am not sure what I have to change. Oh, btw, I found how to set in about:config the webgl.force-enabled to TRUE value. but even that, same message as per picture.

more options

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.171

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Even I think this have nothing together with my issue, I did all those things.

Adobe flash uninstalled - no change. Installed back latest version - no change. Drivers - latest version installed and up to date. Still the same problem. So... any another idea or how to go to previous Firefox version where everything working?

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Safe mode - no change. error page still appear.

no shield icon at all anywhere on tinkercad, so I guess tracking protection is not the issue.

Any another idea?

I am ready to cooperate with Teamviewer session, in case anybody can or want to do it this was, as I am using it when I helping to other people for many other problems, but this issue is far beyond my ability to solve it. Thx

Modified by magy357

more options

Hi, sorry no Teamviewer. It is not how we can do things. As it is users helping other users is what Firefox Support is Volunteers all over the world.

I will say this much about OpenGL I almost never see it working or running in peoples info that gets sent . The best way to find out OpenGl is to google your Video card/chip driverDate: 4-24-2013 and put ATI Mobility Radeon HD 4500/5100 Series+openGL

Please use this URL to Auto Detect drivers for your card/chip : https://support.amd.com/en-us/download/auto-detect-tool

With all the errors you have nothing can be done for you until this is fixed.

Video Card/Chip Errors  : u'Failed - bad | u'unavailable = bad | disabled featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'failed', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'failed', u'message': u'Failed to acquire a D3D11 device', u'type': u'runtime'}]}, {u'status': u'unavailable', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'runtime'}]}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}]}, {u'status': u'available', u'description': u'GPU Process', u'name': u'GPU_PROCESS', u'log': [{u'status': u'available', u'Off Main Thread Painting', u'name': u'OMTP', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'Advanced Layers', u'name': u'ADVANCED_LAYERS', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'available', u'message': u'Enabled for Windows 7 via user-preference', u'type': u'user'}, {u'status': u'unavailable', u'message': u'Requires D3D11', u'type': u'runtime'}]}]}

Please let us know if this solved your issue or if need further assistance.

more options

OK, here is the situation: I already downgraded Mozilla Firefox to ver. 59 something. Page tinkercad immediately run without any problem. But as you suggest, I checked latest version of drivers and that auto detect tool want me to install another version of drivers. Ok, whatever... So I did, restarted laptop and checked tinkercad page with firefox ver.59. Working as usual. Then I upgraded MF to ver. 60 and voilá - page suddenly doesn't work, getting message as per picture on my first post.

So - if WebGL page working in ver. 59 but doesn't in ver. 60, issue have NOTHING to do with graphic card drivers or such things. Mozilla developers obviously must do some particular changes in newer version, that it causing this issue.

Modified by magy357