X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I turn on WebGL in Firefox 4 Beta?

Posted

Hi - how do I turn on WebGL in the new Firefox4 Beta? thanks Nic

This happened

Every time Firefox opened

Chosen solution

as can be found in this article:

- Type “about:config” in your browser’s URL bar - Do a search for “webgl” in the Filter field - Double-click the “enabled_for_all_sites” preference to change it to “true”

that should do it...

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • -http://www.facebook.com/fbplugin/
  • iPhoto6
  • RealPlayer Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Browser Plug-In: Plays DivX video in your browser!
  • O3D Plugin version:0.1.42.3
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Java Plug-In 2 for NPAPI Browsers
  • Unity Web Player lets you experience dazzling interactive 3D right in your browser. For more information, visit Unity .
  • 4.0.50401.0
  • ShiVa3D Plugin 1,8,1,0 for 3D real-time applications made with ShiVa Editor.
  • Shockwave Flash 10.0 r45
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

More Information

Chosen Solution

as can be found in this article:

- Type “about:config” in your browser’s URL bar - Do a search for “webgl” in the Filter field - Double-click the “enabled_for_all_sites” preference to change it to “true”

that should do it...

dadlitt 0 solutions 1 answers

I followed the instructions with no different result.

Alwii 0 solutions 1 answers

I've had tried theses instructions with no results too. The firefox's demo is writing that "Could not initialise WebGL, sorry :-("

martyspence 0 solutions 1 answers

The solution was not applicable. The boolean was already 'true' in my installation. However when I try to use google body browser it behaves like I don't have webGL. When I try and run a demo of webGL it says: "Could not initialise WebGL, sorry :-("

What's the problem here. My graphics car/driver isn't supported?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96960 answers

If you have problems with WebGL then set the pref webgl.verbose to true to see error messages in the "Tools > Error Console"
You may have an unsupported graphics display card.
You may need to enable the "Tools > Error Console" (pref devtools.errorconsole.enabled true)

Geoplace 0 solutions 1 answers

For me the WebGl doesn´t work until I update the video drivers. Try It.

You can take a look for troubleshooting at: http://learningwebgl.com/blog/?p=11

Kurt_Maurer 0 solutions 1 answers

So i have used the about:config changed all parameters to true however to no success when testing the webgl on google body 3d still no response . So i decided just to be a little bit of a traitor and test the Google Chrome browser, and surprise surprise the webgl in the google body 3d worked !!! so I strongly do not believe the graphics card has much to do with this problem , although maybe just because its a google product working the gb3d . but it also worked with other websites with this webgl , not only the gb3d . Maybe Firefox has not quite yet worked around this problem ?!?!?

Cheers

TonyE
  • Moderator
1041 solutions 8840 answers

For some people, installing the DirectX runtime may help. This allows Firefox to use an alternate rendering path that might be better supported on their system, especially on systems with Intel GPUs. Mozilla are working on removing the need for this separate install in a future build.The DirectX runtime is available from http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en&pf=true

This info obtained from http://blog.vlad1.com/2010/12/21/webgl-in-firefox-4-beta-8/

kewp 0 solutions 1 answers

I don't see those configs at all. I only see

webgl.disabled webgl.force-enabled webgl.force_osmesa webgl.osmesalib webgl.prefer-native-gl webgl.shader_validator webgl.verbose

I'm using Firefox 4.0b11

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96960 answers

Do you see any error messages at the bottom of the Help > Troubleshooting Information page about WebGL?

sinu 0 solutions 2 answers

For WebGL Renderer it just says it is unavailable...

Swapnilrustagi 19 solutions 286 answers

WebGL requires that your system has OpenGL ES 2.0 drivers. For systems who don't have these drivers(I also don't have these drivers.) can try using OpenGL Emulators like OSMESA32.dll. Complete detail is on this article - http://blog.vlad1.com/2009/09/21/webgl-samples/ Scroll down on the article till you find: "For those of you on Windows who don’t have an up to date OpenGL driver, or don’t have the possibility of getting one ......................................................Then, flip webgl.software_rendering to true, and you should be good to go."

Follow the instructions on the article

sinu 0 solutions 2 answers

Helpful Reply

For me this works. webgl.disabled false webgl.force-enabled true webgl.force_osmesa false webgl.prefer-native-gl false webgl.shader_validator true webgl.verbose true

STEVIK 0 solutions 1 answers

To Enable WebGL:

1. Type about:config in your browser

2. Mouse Right-Click

3. Choose New - Boolean

4. Type in new appeared window: webgl.enabled_for_all_sites

   Enable = True

5. Restart Firefox.....

6. Goto http://bodybrowser.googlelabs.com/body.html# and give it a try.


For more information, goto:

http://khronos.org/webgl/wiki/Getting_a_WebGL_Implementation

Enjoy!

wendela 0 solutions 1 answers

I have the same problem; I am using KUBUNTU 10.10 as OS

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96960 answers

The pref webgl.enabled_for_all_sites is no longer used in Firefox 4.

I see these in the source code referenced:

webgl.disabled (f)(global)
webgl.enabled (t)
webgl.force-enabled (f)
webgl.force_osmesa (f)
webgl.prefer-egl (u)
webgl.prefer-native-gl (f)

You can try to toggle the pref webgl.prefer-native-gl to true.

You can also check the Help > Troubleshooting Information page for error messages (look at the bottom).

alcasistemi 0 solutions 1 answers

Helpful Reply

Hello,

I solved this problem in this way:

Firefox 4 RC:

  1. Type about:config
  2. Type in the search box webgl
  3. webgl.force-enabled = true
  4. visit http://bodybrowser.googlelabs.com/ refresh the page and enjoy!

Modified by alcasistemi

Steve.Nordquist 0 solutions 2 answers

Fair enough try; what videocard and drivers do you happen to have, Apple ATI X600 (G4 iMac?) You can always try a particular workaround per the LearningWebGL.com (thanks, Geoplace) FAQ (using GreaseMonkey to auto-insert it, for example):



"Old ATI graphics drivers

For certain old ATI graphics drivers, in particular those shipped with HP computers, you may find that textures do not appear when you display WebGL pages unless those pages include this JavaScript code:

gl.enable(gl.TEXTURE_2D)

The code is actually invalid WebGL, gl.TEXTURE_2D should not be accepted by gl.enable. However, there is a bug in some graphics drivers that makes it necessary to put the code in if you want WebGL to work.

Your best bet is to update your drivers if you can. "

bjacob 2 solutions 11 answers

WebGL is turned on by default in Firefox 4.

To check if it's working for you, go to: http://doesmybrowsersupportwebgl.com/

If it's not working for you, that means that either you don't have Direct3D 9 / OpenGL 2.1+ / ES2.0+ drivers, or your driver is getting blacklisted.

If you're getting blacklisted, see this wiki page: https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers

It explains how to force-enable WebGL if you want to.

Munawwar 0 solutions 1 answers

At about:config I set webgl.force-enabled and webgl.prefer-native-gl to true. Also created a webgl.enabled_for_all_sites boolean and set it true (just in case it's needed?). Still it failed to work.

I then updated my graphic drivers (got the new GeForce/ION drivers) - restarted browser. Now it works :)