X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 3.6.3 wont play embedded youtube videos. It comes up with "an error occured please try again later. this happens all the time

Posted

Firefox 3.6.3 wont play embedded youtube videos. It comes up with "an error occurred please try again later. this happens all the time. If you click to go to youtube the clip plays.

This happened

Every time Firefox opened

Chosen solution

Well, here is my reply to my own post.

After reading some of the messages posted here about possible solutions, I tried deleting all YouTube cookies (tools > options > privacy > show cookies > youtube.com). Then tested on a site with embedded video that would not play previously and on YouTube site directly--both worked!

The poster with the cookies suggestion also suggested changes to "exceptions" but this was not necessary at least for me.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • -6.0.12.1040
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Mozilla ActiveX control and plugin module
  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape
  • Default Plug-in
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Google Update
  • Java Plug-in 1.6.0_02 for Netscape Navigator (DLL Helper)
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

Question owner

Hi,

You may need to update your flash for it here is the link. www.adobe.com/products/flashplayer

I hope this helps if not please post again and i will find more information.

Kind Regards,


Cody Bush (cbush15)

Question owner

Same thing... WinXP, Firefox 3.6.4, Flash 10.1.53.64. Been happening a while, maybe a month or so? Embedded videos give that error, but clicking on it to watch at youtube works fine.

Question owner

On some sites, embedded youtube videos are completely blank. Youtube site works fine.

Firefox and flash are up to date.

Vista, Firefox 3.6.4, Flash 10.1.53.64

Question owner

Same problem here--embedded videos worked a while back and now with the *very* recent upgrades of Firefox, they don't. This happens everywhere I've gone that's had embedded Youtube videos. On the Youtube site, they work fine.

I have Win 7, FF 3.6.6 & updated to latest version of Flash.

Question owner

Same problem here

Youtube videos take forever to load, often they end up with an error. Embdedded don't work etc ...

Question owner

And I'll add that the Apple site doesn't load correctly either.

Question owner

Had the same issue with embedded videos not displaying...just a blank space... I went through and disabled all my Add-ons and videos began working. I enabled most of my disabled add-ons and videos still work. I'm not entirely sure which add-on might be the culprit, or maybe just the action of disabling, restarting firefox, then re-enabling them fixed the glitch. But for now, everything is working.

Question owner

Firefox 3.6.6 and Windows XP. Plays videos just fine on YouTube site but will not play embedded YouTube videos. Get message "An error occurred. Please try again later." Deleted & reinstalled Flash Player--no soap.

If I run Explorer 8 I can see embedded videos just fine.

Chosen Solution

Well, here is my reply to my own post.

After reading some of the messages posted here about possible solutions, I tried deleting all YouTube cookies (tools > options > privacy > show cookies > youtube.com). Then tested on a site with embedded video that would not play previously and on YouTube site directly--both worked!

The poster with the cookies suggestion also suggested changes to "exceptions" but this was not necessary at least for me.

Question owner

I posted earlier about embedded youtube videos not working. Steve's suggestion of deleting youtube cookies fixed it for me.

bababa 0 solutions 1 answers

I had the same problem, and I think it was my Adblock Plus program. I think it was blocking the embedded Youtube videos.

So I went into Adblock Plus settings and made an exception for Youtube-related stuff. The problem was solved. Now I can see embedded Youtube videos.

I'm not saying it will work for everyone, but it worked for me.

viciousknid 0 solutions 1 answers

Helpful Reply

I was having the same issue up until I found a solution myself a few minutes ago. If you have "Accept Third Party Cookies" un-checked it will not allow the embedded "Third party" youtube videos to load. You can either Check the box to allow third party cookies or add an exception to allow youtube.com WITHOUT the www. You just want it to be Youtube.Com.

To do so just go to Tools: Options: Privacy: Exceptions: Type in Youtube.com and click Allow. Then click Close and OK. It should start working immediately.

gatesspam1 0 solutions 2 answers

I had the same problem...

If I even tried to view a YouTube video that was embedded in another site, I received the following error: "an error occurred please try again later."

But, I followed the advice of this post and...

  • Tools --> Clear Recent History
  • selected "Everything"
  • checked all of the boxes
  • clicked "Clear Now"

And I no longer have the problem. Thanks for the advice!

www.CheapSilver.info 0 solutions 1 answers

Thanks, viciousknid! Rather than enable ALL third party cookies, I just allowed www.youtube.com in the exceptions - problem solved!

cancunlee 0 solutions 1 answers

I'm going crazy. I've been getting messages "An error occurred. Please try again later". Now I'm also getting the message "Embedding disabled by request. Watch on You Tube" (with a link). By request?? I'm running Vista, Firefox 3.6 (3.6.13), already had but again updated Flash (10.2.152.26), enabled all 3rd party cookies, then tried just adding youtube.com as exception, deleted all youtube cookies. I haven't cleared all cookies as there are many sites that I need to recognize me (e.g., financial institutions). I have no problem when actually on youtube.com. Help!

BCJ1974 0 solutions 1 answers

It seems to be my AdBlock Plus ad-on, because when I deactivated it, the YouTube embeds started to show on other sites and forums. But I wouldn't want to give up the useful ad-on.

EDIT:// Apparently clicking Ctrl+shift+V and removing the block on any site where it blocks a YouTube embed, helps every page and you can keep the ad-on active.

Well, at least for now that worked, at least for me. :)

Modified by BCJ1974

Guy... 0 solutions 9 answers

I've had this problem for ages, and I finally solved it with the help of: http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-....

This solution will reset your settings to which sites you allow or deny to set cookies, display images, open popup windows and initiate extensions installation.

1. Close Firefox

2. Start >> Run >> firefox.exe -p

3. Create Profile >> Next >> Finish >> Start Firefox

4. Close Firefox

5. Go to C:\Documents and Settings\[Your User]\Application Data\Mozilla\Firefox\Profiles

6. Copy the file permissions.sqlite from the new profile folder to the original profile folder

7. Start Firefox

madmacman 0 solutions 1 answers

I was experiencing the problem, I went to Adblock Plus preferences and unchecked YouTube. It worked instantly with no more issues. In my particular case clearing history, cookies and repairing the Mac disk did not solve the problem

Alison321 0 solutions 2 answers

Helpful Reply

This below was my solution to the error message on YouTube videos while using the Firefox browser, "An error occurred. Please try again later." I have Windows Vista 64-bit operating system. I hope this helps below.

If RealPlayer is installed, try this first Turn off Web Download & Recording in RealPlayer

   Launch RealPlayer
   Click the RealPlayer icon in the upper left corner of the window and choose Preferences.
   Choose Download & Recording from the left hand panel
   Uncheck "Enable Web Download & Recording for these installed browsers"
   Click OK and close RealPlayer
   Restart Firefox 

Note: This will remove the RealPlayer Browser Record extension from the Firefox Add-ons Manager.

goducks 0 solutions 1 answers

Alison321, Thank you. This solution worked for me! I have Windows 7 64-bit, not Vista, but I do have RealPlayer installed. It's nice to find a simple solution. Anybody else with a similar configuration, I'd recommend trying this.