X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why won't firefox clear my search and form history? it's greyed out whenever i try to clear it.

Posted

i am not in private browsing mode and still can't clear this history

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

If you can't clear that saved form and search history then there may be nothing to clear.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions. You have to close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") .......... Form History Control: https://addons.mozilla.org/firefox/addon/12021

Question owner

my search and form history is greyed out in the tools clear history dropdown. i would like to delete it. any suggestions

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

Rename or delete formhistory.sqlite (plus formhistory.sqlite-journal and formhistory.sqlite.corrupt and formhistory.dat, if they exist) in the Profile Folder in case there is a problem with the file that stores the "Saved Form" data. This will remove all saved form data, so you may want to rename formhistory.sqlite to formhistory.sqlite.sav or move the file to another folder in case you need to recover some saved data.


Help > Troubleshooting Information > Profile Directory > Open Containing folder See also Use the Troubleshooting Information page to help fix Firefox issues

ranggadee 0 solutions 1 answers

hi, if you don't want to remember any history at all, just go to 'Firefox'>'Preferences'>'Privacy'>in 'History' choose 'Never Remember History' in the drop box. and in 'Location Bar' choose 'Nothing' in the 'When using the location bar suggest:...' -drop box.

And if you want to make Firefox can't remember all your typed in passwords, just go to 'Firefox'>'Preferences'>'Security'> in 'Passwords' uncheck the 'Remember passwords for sites'

with all these steps, you'll no longer be able to access the 'Clear Recent History' in 'Tools' tab. thanx

karateman 0 solutions 1 answers

I have done all above like "never remember history" and "nothing" in location bar and also deleted formhistory.sqlite and also tried renaming it but when I load firefox again it reappears and it still brings up past history and pages when I start to type web page addresses and everything seems to have reverted back to previous settings.

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

@karateman

You seem to have a problem with the location bar and not with the search bar where this thread is about.

A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history.

monsoon 0 solutions 1 answers

heh, the reason is simple. when you setup firefox, you unchecked the boxes for 'remember search and form history'. It never remembers it, and therefore there's never anything to delete. Hence the box being grayed out in your "clear recent history".

jamesjeffrey29 0 solutions 1 answers

Try this. Go to tools. Privacy. Settings. There is a box you can check which will delete your form history upon closing Firefox. I have version. 3.6.8 Hope this helps. It works as somehow this problem arose recently for me , for some reason. Also do not track. com is a free add on you can get. It really works. And hey it's free.