X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox redirects to wyciwyg page

Posted

For the past couple of days Firefox always redirects to a blank page when I try to visit any page on www.kongregate.com. When I use IE tab on the blank page it comes up with the url "wyciwyg://#/www.kongregate.com" where # is a number that changes occasionally. I've tried deleting my Firefox cache and uninstalling/reinstalling Firefox with no success. Kongregate.com is the only site I know this to happen on and this is the first time I've seen it do this before. It was fine two days ago and I haven't installed a new add on in months.

URL of affected sites

http://www.kongregate.com

Chosen solution

I've restarted my computer, turned it off for a while, deleted the cache by manually going into the folders, and disabled several plugins and yet the issue remains.

Any more ideas on how to fix this problem?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -IE Tab Plug-in for Mozilla/Firefox
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.2
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • getplusplusadobe16260
  • npdivxplayerplugin
  • DivX Web Player version 1.5.0.52
  • 1.7.0069.2
  • Coupons, Inc. Coupon Printer DLL
  • Adobe Shockwave for Director Netscape plug-in, version 10.3
  • np-mswmp
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50524.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • NPVeohTVPlugin
  • Veoh Web Video Player Browser Plugin
  • Yahoo! activeX Plug-in Bridge
  • Next Generation Java Plug-in 1.6.0_19 for Mozilla browsers
  • Java(TM) Platform SE binary

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

More Information

Flashblock 1.5.13
IE Tab 1.5.20090525
Java Quick Starter 1.0 (disabled)
Search Helper Extension 1.0
Veoh Web Player Video Finder 1.4 (disabled)

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96650 answers

The wyciwyg protocol is used internally for pages retrieved from the cache. You shouldn't see that protocol under normal circumstances. So it looks that you have a problem with the cache for at least that website.

You can try to clear the cache, but it may be necessary to clear the cache folder on disk. You can see the location of the cache on the about:cache page (open that page via the location bar like a website).

"Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

Question owner

I deleted my cache by using the Options menu and by going to the folder and deleting the files. I restarted Firefox after each try but neither way have solved my problem. Any other ideas are appreciated.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96650 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit")

Question owner

I'm seeing the same problem. Safe mode isn't helping.

I actually see the page I expect for a split second, then it goes white and spins like it's trying to load something.

Question owner

Starting Firefox in safe mode didn't fix my problem.

Seems the previous poster has the same issue. I can see the site for one or two seconds before the page redirects and tries to load something but never finishes.

I tried going to a page on Kongregate today that I've never visited by typing the url directly and see that the redirect still happens.

Chosen Solution

I've restarted my computer, turned it off for a while, deleted the cache by manually going into the folders, and disabled several plugins and yet the issue remains.

Any more ideas on how to fix this problem?

wickedwig 0 solutions 1 answers

Helpful Reply

I have the same problem as the previous poster and have wasted valuable hours searching for a solution to no avail. I have installed a battery of useless plugins, followed all the instructions suggested here, step by step, and the problem persists. I've tried this both on a PC and a Mac and the results are the same. The only way I can see the page I am looking for without it redirecting (in exactly the same way as AnonmousUser describes in the previous two posts) is by accessing the Google cached version.

I don't have a PhD in computing and many of the potential fixes to this that I have found through more general searches are couched in terms that make me glaze over and run for a coffee break.

This problem seems to be quite widespread - how difficult could it be to devise a one-click fix that doesn't require any coding or other complications that the non-tech-savvy simply don't understand?

Xyrec 0 solutions 2 answers

I have the same problem! When I go to bit.ly, www.mmo-champion.com or rejseplanen.dk, I see the page for a split second, then it starts loading "wyciwyg://(0-9)/(website).com"

I've tried to manually set the cache size, and completely turn off caching in about:config but it didn't help.

I tried downloading Opera, but got the same problem in Opera, and after searching for the problem on google, I see that some people also have the problem in Chrome as well.

The only browser that works, is Internet Explorer.

Please help us!

Modified by Xyrec

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96650 answers

Do a malware check with a few malware scan programs.
You need to use all programs because each detects different malware.
Make sure that you update each program to get the latest version of the database.

See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked and What to do when searches take you to the wrong search website

bredkramm 0 solutions 1 answers

also ko.koramgame.com for me is affected before it redirects me to domaindiscount24 then now it's on goggle-analytics WTH

Xyrec 0 solutions 2 answers

I solved the problem! Change your DNS servers! My router somehow managed changing it to the default DNS servers, but when I changed back to OpenDNS, I didn't get the redirects anymore!

ewms 0 solutions 1 answers

i had the exact same problem. Page loads and disapears after a second but only on some specific pages.

Changing the DNS did solve the problem for me. But i had to flush my DNS cache for the change to take effect.

You can flush your DNS cache like this:
Windows: ipconfig -flushdns ( you might need to do ipconfig /renew as well )
OSX (Tiger): lookupd -flushcache
OSX (Leopard): dscacheutil -flushcache

I have no idea how the DNS-Server causes the firefox cache to go crazy but i tested changing the DNS on two machines before i did it on the router. Worked like a charm.

RuneUlvson 0 solutions 1 answers

I see the page for a split second, then it starts loading "wyciwyg://(0-9)/(website).com"

I have had the same thing happening to me for months when I visit the oregonwild.org page. I have no problem accessing the page in Opera, Chrome, or IE.

Flushing the DNS cache and resetting the DNS servers did not help.

Running in Firefox Safe Mode does fix the problem. However, I have a couple dozen add-ons and I have not figured out what combination of them are causing trouble. Wish there was an easier way to get to the bottom of this.

GeniusZX 0 solutions 1 answers

Helpful Reply

I've been experiencing the exact annoying problem for the last 2 weeks, just like the way the users above describe it. I don't know what exactly caused it (nobody seems to do :-), although I can tell that it started right after uninstalling an unwanted Softonic-Eng7 Toolbar, installed with some other software. It may have some relation to the problem, it may not.

It was just strange that it occurs only with some few sites that I use, not with others. I only want to add that while the blank page kept loading, there was a "loading data from gostats.com" message in the FF status bar. When I hit the same site with IE, it just crashed!...

I tried the solutions mentioned above (running FF in safe mode, DNS changing and flushing), nothing worked, the problem persisted. Until now, that I installed the NoScript add-on, found here: http://noscript.net/

It prevents some script loaded with the page from running, and the redirection to the wyciwyg page just doesn't happen!!!

It obviously doesn't cure the "disease", but it most surely eliminates the "symptom", so it's a good solution until something else more efficient is found. I recommend it, as it may be also be helpful with other issues caused by malware script in some sites.

I'll be glad to know the cause of the "wyciwyg problem" some day by a FF developer, if they had the interest to deal with it. And hopefully the future versions of FF won't suffer by it any more... :-)

shadowblack 1 solutions 4 answers

I now have this problem too. The first time I encountered it clearing the cache and starting Firefox in Safe Mode was all it took to fix it. Not this time – even in Safe Mode the problem is there.

Both times the problem appeared after I restarted my PC without manually closing Firefox first (so it was closed during the restart; both times I selected the option to save my opened tabs so they would open next time I started Firefox).

Affected sites: http://dragcave.net/ http://isohunt.com/ (only the main page, it seems)

I had the problem with at least three other pages I can’t remember right now. :( All affected pages stall at “Read gostats.com

Firefox 3.6.10 on Win XP Service Pack 3

P.S.: Yes, I checked for malware and viruses.

Modified by shadowblack

star_man_20 0 solutions 1 answers

I am having this problem too. in safe mode, no plug ins, deleted the cache, hasn't fixed it. also tried running the multiple anti-virus programs I have on my computer, Symantec doesn't seem to find the problem, but this is where my situation gets REALLY crazy. I cannot open the Malwarebytes program on my computer (it gives me a run-time error). I am further thwarted as I cannot go to malwarebyte's website, piriform.com (for ccleaner), OR safer-networking.org (spybot search and destroy) to download/update the antivirus definitions. this problem is ridiculous.

and why the hell does the wyciwyg pseudo-redirect me to "www.google.analytics.com"??? you'd think that by doing that google would have crushed these guys(/gals?) by now.

crozilla 0 solutions 2 answers

I've been having this problem, too. Running NoScript doesn't seem to help. Oddly, it only happens on specific websites. Most of the time, FF works fine, but every once in awhile I get the wyciwyg cache thing.

baparks 0 solutions 2 answers

This is annoying as all get out!!!!! I have the SAME ISSUE and nothing here has helped!

crozilla 0 solutions 2 answers

Oh, yeah. Also, I can reach the same webpages easily and without problem using Stainless or Safari or IE. If that helps.

baparks 0 solutions 2 answers

Use another browser to go to Malwarebytes and download their program. (The free version will suffice.)

Once installed, rename the executable by placing (at least) a character (like x) in front of the actual executable name. (It normally installs in c:\program files...)

("C:\Program Files\Malwarebytes' Anti-Malware\Xbam.exe")

Run the program. (probably more than once, to be safe) That MAY get you back on the road to recovery for a minute.

Follow the same steps when using ccleaner.

This is DEFINITELY some sort of virus or malware or rootkit directed at firefox.

I have a mac that I use as well as my pc. BOTH run firefox and only the pc has issues.

Following the above steps helped me clear most of my issues up pronto!

Once you get rid of the OBVIOUS spyware, malware, trojans and rootkits, that you find on your local hard drive, be sure to thoroughly clean your usb drives.

Be prepared to spend a little time doing this. All my hard drives are terrabytes and above so I just started the program and went to bed.

Modified by baparks