Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't start despite not being already running task manager process

  • 2 replies
  • 60 have this problem
  • 71 views
  • Last reply by Chris Ilias

more options

I have recently updated my Firefox version to the latest 3.6.3. I had the feeling the installer donload was not quite "complete", and after installing and running the installer I tryed adding plugins but the latest ones said I have version "3.0.5 MEGAUPLOAD" (I think). I assumed that was caused by the download not really finishing (appears as done after 97% was downloaded), so I redownloaded it and made sure it got up all the way to 100%, using a different download manager. It worked, and I installed firefox again with the completely downloaded installer. When I tried opening it nothing happened, and I checked the task manager but no firefox process was running.

All Replies (2)

more options

Does it work if you start in Firefox Safe Mode? See Diagnose Firefox issues using Troubleshoot Mode

more options

Check the general.useragent prefs on the about:config page. You can open the about:config page via the location bar, just like you open a website. Filter: general.useragent If any general.useragent prefs are bold (user set) then right-click that pref and choose Reset.

See Find what version of Firefox you are using and Web sites or add-ons incorrectly report incompatible browser See also http://kb.mozillazine.org/Resetting_your_useragent_string_to_its_compiled-in_default