X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

fire fox wont store passwords and wont prompt to store passwords

Posted

fire fox wont store passwords

Chosen solution

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.0 r45
  • 3.0.40624.0
  • NPWLPG
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

fire fox wont store my passwords and wont prompt to store passwords, went to privacy under settings and it doesnt have the options for settings as it stated in the help section

Chris Ilias
  • Moderator
116 solutions 1065 answers

Chosen Solution

Maybe this article will help: Usernames and passwords are not saved

cor-el
  • Top 10 Contributor
  • Moderator
10781 solutions 97024 answers

Helpful Reply

Make sure that you not run Firefox in Private Browsing - Browse the web without saving information about the sites you visit mode. In Private Browsing mode some menu items are disabled (grayed) and some features like visited links and others are disabled and not working. You are in Private Browsing mode if you see "Tools > Stop Private Browsing". See Private Browsing - Browse the web without saving information about the sites you visit and http://kb.mozillazine.org/Issues_related_to_Private_Browsing ..... You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" To see all History settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history UnCheck: [[ ] "Automatically start Firefox in a private browsing session"

See also: http://kb.mozillazine.org/User_name_and_password_not_remembered (bookmarklet) http://kb.mozillazine.org/Password_Manager (Troubleshooting)

jtw0728 0 solutions 1 answers

The problem for me was this.. My remember passwords bar would pop up, the buttons for "not now" and "never for this site" would work, but the remember button wouldnt. I tried everything i could find to fix this.. finally.. this worked for me.. I deleted the "cookies.sqlite", "key3.db","signons.sqlite" from this directory.. you must make sure that hidden files is shown.. users>yourprofile>AppData>Roaming>Mozilla>Firefox>Profiles>something.default> Sorry this is in Windows 7.. after i deleted those three file 'bingo' my Firefox now remembers passwords.. Hope this helps anyone..

bama006 0 solutions 1 answers

This sucks. I've tried everything and still can't get Firefox to save usernames or passwords. Using Windows 7. Any ideas before I have to start using IE again..??

cor-el
  • Top 10 Contributor
  • Moderator
10781 solutions 97024 answers

Do you mean names and passwords in the Password Manager or do you mean that you are no longer logged on to (remembered by) websites after closing and restarting Firefox?

  • Websites remembering you and automatically log you in is stored in a cookie.
  • You need an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep that cookie, especially for secure websites and if you let cookies expire when Firefox closes
  • Make sure that you do not use Remove recent browsing, search and download history to clear the "Cookies" and the "Site Preferences"

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Automatically start Firefox in a private browsing session"

See also http://kb.mozillazine.org/Password_Manager (Troubleshooting)