Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Notification about Upgrading by 31 march 2024

  • 2 replies
  • 1 has this problem
  • 48 views
  • Last reply by James

more options

Hi I recieved an Email Notification From Firefox Mozilla saying that i need to Upgrade my Forefox Browser on my MacBook Pro 2009 ( Operating System Yosemite Version 10.10.5 ) by 31st of march.my Firefox is set to update automatically

 so,  Is this a Legit Notification or a scam 
and , if legit, how do i go about doing it without updating my Operating system
   any info would be appreciated !
  Sam
Hi I recieved an Email Notification From Firefox Mozilla saying that i need to Upgrade my Forefox Browser on my MacBook Pro 2009 ( Operating System Yosemite Version 10.10.5 ) by 31st of march.my Firefox is set to update automatically so, Is this a Legit Notification or a scam and , if legit, how do i go about doing it without updating my Operating system any info would be appreciated ! Sam

All Replies (2)

more options

Hi Sam, the message is about services connected to your Firefox/Mozilla Account.

As I understand it, something is changing on the back end related to how you sign in. The method used in Firefox 78 ESR and earlier is being discontinued. That will prevent Firefox 78 ESR from connecting.

This is a big problem if you use Sync, Pocket, or other services linked to your account. What services? For reference, see: Access Mozilla services with a Mozilla account.

Unfortunately, updating Firefox without a system update isn't a solution for you because you already have the latest version of Firefox available for your version of MacOS (Firefox Mac OS X 10.9, 10.10 and 10.11 users move to Extended Support Release).

Hopefully someone else will have a suggestion.

Helpful?

more options

Firefox 116.0 and later requires macOS 10.15 (ten.fifteen) at minimum to run while Firefox 79.0 to 115.0 required macOS 10.12, 10.13, 10.14 to run.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.