Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Sites are often not saving login

  • 1 reply
  • 0 have this problem
  • 1 view
  • Last reply by cor-el

more options

Hello Before I reset my PC some months ago, I almost never had to Login to sites, as the kept me logged in. This no longer happens, and now I frequently have to Login to eg. my Google account which needs third party autho and all sorts. It is rather annoying having to Login to Google every time I close the Window.

I do not have this setting on: "delete cookies and site data when Firefox is closed" I do have this setting on: "Ask to save logins and passwords for web sites"

It does save my Password and autofill, which makes it easier. But it is still annoying, that I have to login to everything every time.

I have tried reinstalling Firefox, to no avail.

Please Help

Hello Before I reset my PC some months ago, I almost never had to Login to sites, as the kept me logged in. This no longer happens, and now I frequently have to Login to eg. my Google account which needs third party autho and all sorts. It is rather annoying having to Login to Google every time I close the Window. I do not have this setting on: "delete cookies and site data when Firefox is closed" I do have this setting on: "Ask to save logins and passwords for web sites" It does save my Password and autofill, which makes it easier. But it is still annoying, that I have to login to everything every time. I have tried reinstalling Firefox, to no avail. Please Help

All Replies (1)

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Detail like websites remembering you and log you in automatically is stored in cookies, so make sure you aren't clearing important cookies.

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" to clear cookies keeps cookies with an allow exception
    in 102+ version toggling this setting makes changes to the "Clear history when Firefox closes" settings and those settings prevail
  • using "Clear history when Firefox closes" in Firefox 102+ honors exceptions and keeps cookies with an allow exception, previous versions removed all cookies

Make sure to keep the "Site settings".

  • clearing "Site settings" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.