Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube bottom left corner URL won't go away - full solution

  • 4 replies
  • 0 have this problem
  • 8 views
  • Last reply by zeroknight

more options

Moderators, I am copy and pasting the below warning I have seen on similar posts at the top of the post.

--- WARNING: This script is not provided by Mozilla and is not officially supported Creating a userChrome.css file and other ways of customizing Firefox that are not exposed in the interface are there for developers, not end-users. If it were intended for end-users, you would see a menu option or checkbox; you wouldn't have to hack a text file in a hidden location.

What this means is that even though the functionality you want is no longer supported, a third-party has found a way to do it using the CSS file. If it breaks in new versions, you will need to contact the person who provided the script.

[Warning was not added by moderator, but by me to save someone time.] ---

With that out of the way, here's the issue I have, how I've solved it temporarily for the community.

When I load YouTube videos, I am given a statuspanel message with the URL of the video playing. It's not momentary or temporary, it stays there, the entire time. Why anyone thought this was a good idea, I'm not sure.

My question is simple, is there an alternative solution - to remove this statuspanel message permentantly - to what I'm sharing here, without using the userChrome.css file?

If so, please provide the solution so it can be tested and upvoted by the community, thank you in advance if that is you.

If there is not, then this post also serves as solution as well as a request to Modzila, that being.

Modzilla. Please make a solution that doesn't need custom .css scripts.

I am posting this as I needed multiple posts to achieve a solution so am hoping this serves as that for someone (including myself) until Firefox resolves this issue themselves, another way.

Solution: Windows 7/8/10/11 as of Firefox version 120.0

1. Go to about:config, click Accept the Risk and Continue 2. Type "toolkit.legacyUserProfileCustomizations.stylesheets", toggle this to true 3. Close all instances of Firefox 4. Open Explorer, navigate to %appdata% then navigate down to \Mozilla\Firefox\Profiles and select your profile folder. If you only have 1 it may be obvious, if not for me it's the only "~.default-release" folder, where ~ is a random set or letters and numbers. If you're unsure, pick the first folder named like this, then repeat the next steps for all profile folders, or use trial and error if you prefer until you achieve the desired result. 5. Make a new folder "chrome" in that folder. 6. In this folder make a new .css file, right click make a new .txt file rename the file and extension "userChrome.css". 6. Open the blank .css file with a text editor and paste this line without quotes "#statuspanel {display:none!important;}" and save. 7. Attempt to load videos or pages where messages usually appear in the bottom left and observe the results

There are various other posts both here and other places that I have combined to write this solution, none of the others worked on their own, for me, which is why I write this and to refresh the request to the Modzilla Firefox team, to please, share or make a solution so we don't have to do this, as you'll otherwise need to continue supporting this legacy feature in future versions of Firefox.

Note: This will likely remove all statuspanel messages on other pages too, I have read other statuspanel commands online so if you want to be particular about muting some and not others, you may need to modify the file further.

Moderators, I am copy and pasting the below warning I have seen on similar posts at the top of the post. --- WARNING: This script is not provided by Mozilla and is not officially supported Creating a userChrome.css file and other ways of customizing Firefox that are not exposed in the interface are there for developers, not end-users. If it were intended for end-users, you would see a menu option or checkbox; you wouldn't have to hack a text file in a hidden location. What this means is that even though the functionality you want is no longer supported, a third-party has found a way to do it using the CSS file. If it breaks in new versions, you will need to contact the person who provided the script. [Warning was not added by moderator, but by me to save someone time.] --- With that out of the way, here's the issue I have, how I've solved it temporarily for the community. When I load YouTube videos, I am given a statuspanel message with the URL of the video playing. It's not momentary or temporary, it stays there, the entire time. Why anyone thought this was a good idea, I'm not sure. My question is simple, is there an alternative solution - to remove this statuspanel message permentantly - to what I'm sharing here, without using the userChrome.css file? If so, please provide the solution so it can be tested and upvoted by the community, thank you in advance if that is you. If there is not, then this post also serves as solution as well as a request to Modzila, that being. Modzilla. Please make a solution that doesn't need custom .css scripts. I am posting this as I needed multiple posts to achieve a solution so am hoping this serves as that for someone (including myself) until Firefox resolves this issue themselves, another way. Solution: Windows 7/8/10/11 as of Firefox version 120.0 1. Go to about:config, click Accept the Risk and Continue 2. Type "toolkit.legacyUserProfileCustomizations.stylesheets", toggle this to true 3. Close all instances of Firefox 4. Open Explorer, navigate to %appdata% then navigate down to \Mozilla\Firefox\Profiles and select your profile folder. If you only have 1 it may be obvious, if not for me it's the only "~.default-release" folder, where ~ is a random set or letters and numbers. If you're unsure, pick the first folder named like this, then repeat the next steps for all profile folders, or use trial and error if you prefer until you achieve the desired result. 5. Make a new folder "chrome" in that folder. 6. In this folder make a new .css file, right click make a new .txt file rename the file and extension "userChrome.css". 6. Open the blank .css file with a text editor and paste this line without quotes "#statuspanel {display:none!important;}" and save. 7. Attempt to load videos or pages where messages usually appear in the bottom left and observe the results There are various other posts both here and other places that I have combined to write this solution, none of the others worked on their own, for me, which is why I write this and to refresh the request to the Modzilla Firefox team, to please, share or make a solution so we don't have to do this, as you'll otherwise need to continue supporting this legacy feature in future versions of Firefox. Note: This will likely remove all statuspanel messages on other pages too, I have read other statuspanel commands online so if you want to be particular about muting some and not others, you may need to modify the file further.

All Replies (4)

more options

I'm not sure what message this is about. You normally only see messages appearing while the page in loading phase (#statuspanel[type="status"]) and if you hover a link (#statusbar[type="overlink"])

Is the page stuck in loading phase (moving dot on the Tab bar) ?

Can you attach a screenshot?


Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

MrOtherGuy has a script to hide the status panel when the tab is in full screen.

more options

For hiding the status messages in full screen, that would be CSS code like this:

:root[inFullscreen] #statuspanel-label {opacity: 0 !important;}

Modified by cor-el

more options

This should be fixed in version 120.0.1 by Bug 1853896.