Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hide Bookmarks bar shortcuts text.

  • 1 reply
  • 0 have this problem
  • 118 views
  • Last reply by meromex_102

more options

there used to be an add on called roomy bookmarks that stopped working so people found ways around to replicate it and it works on win 10 but I just switched to Win 11 and this solution doesnt seem to work anymore for me, anyone know if i need to change anything?

    Locate your firefox profile folder, in this article they say where you can find it: http://kb.mozillazine.org/Profile_folder
   Find your profile folder mine was: C:\Users\***\AppData\Roaming\Mozilla\Firefox\Profiles\***.default\
   Locate a folder called chrome (if it doesn't exists create one through your O.S) must be lowercase
   Locate inside chrome folder the file: userChrome.css (if it doesn't exists create one through your O.S, google how to create a .css file on notepad) Chrome must be cased as shown above
   Add the code: https://pastebin.com/1r6cc8hW
   Restart Firefox, now you are done, if you don't want text to be displayed within the icons just remove the last line. 

This is the line of code i have in css file that works for me in my win 10 machine.

/*

* Recreates the basic functionality of the popular Roomy Bookmarks Toolbar add-on in Firefox 57+.
* Uncomment the section with the functionality that you want, leave all other sections commented.
* This only affects toplevel toolbar bookmarks and folders, bookmarks and subfolders in folders are unaffected.
* The tooltips on long hover (showing bookmark name and link) are unaffected.
*/
/* some margin settings, do not comment out */

.bookmark-item > .toolbarbutton-text {

 margin-top: -1px !important;

} .bookmark-item {

 margin: -1px !important;

}


/* No text on toolbar bookmarks; Text on bookmark folders. No hover effect. */

  1. PlacesToolbarItems > .bookmark-item:not([container]):not([open="true"]) > .toolbarbutton-text {
 display: none !important;

}

  1. PlacesToolbarItems > .bookmark-item:not([container]):not([open="true"]) > .toolbarbutton-icon[label]:not([label=""]) {
 margin-inline-end: 0px !important;

}


/* No text on toolbar bookmarks; No text on bookmark folders. Show bookmark text on hover. */ /*

  1. PlacesToolbarItems > .bookmark-item:not(:hover):not([open="true"]) > .toolbarbutton-text {
 display: none !important;

}

  1. PlacesToolbarItems > .bookmark-item:not(:hover):not([open="true"]) > .toolbarbutton-icon[label]:not([label=""]) {
 margin-inline-end: 0px !important;

}

  • /


/* No text on toolbar bookmarks; Text on bookmark folders. Show bookmark text on hover. */ /*

  1. PlacesToolbarItems > .bookmark-item:not(:hover):not([container]):not([open="true"]) > .toolbarbutton-text {
 display: none !important;

}

  1. PlacesToolbarItems > .bookmark-item:not(:hover):not([container]):not([open="true"]) > .toolbarbutton-icon[label]:not([label=""]) {
 margin-inline-end: 0px !important;

}

  • /

does anyone have a workaround or a similar add on? i would like to have my booksmarks as shown in the screenshot on my win 11 pc as well.

there used to be an add on called roomy bookmarks that stopped working so people found ways around to replicate it and it works on win 10 but I just switched to Win 11 and this solution doesnt seem to work anymore for me, anyone know if i need to change anything? **** Locate your firefox profile folder, in this article they say where you can find it: http://kb.mozillazine.org/Profile_folder Find your profile folder mine was: C:\Users\***\AppData\Roaming\Mozilla\Firefox\Profiles\***.default\ Locate a folder called chrome (if it doesn't exists create one through your O.S) must be lowercase Locate inside chrome folder the file: userChrome.css (if it doesn't exists create one through your O.S, google how to create a .css file on notepad) Chrome must be cased as shown above Add the code: https://pastebin.com/1r6cc8hW Restart Firefox, now you are done, if you don't want text to be displayed within the icons just remove the last line. **** This is the line of code i have in css file that works for me in my win 10 machine. ********************************************************************************** /* * Recreates the basic functionality of the popular Roomy Bookmarks Toolbar add-on in Firefox 57+. * Uncomment the section with the functionality that you want, leave all other sections commented. * This only affects toplevel toolbar bookmarks and folders, bookmarks and subfolders in folders are unaffected. * The tooltips on long hover (showing bookmark name and link) are unaffected. */ /* some margin settings, do not comment out */ .bookmark-item > .toolbarbutton-text { margin-top: -1px !important; } .bookmark-item { margin: -1px !important; } /* No text on toolbar bookmarks; Text on bookmark folders. No hover effect. */ #PlacesToolbarItems > .bookmark-item:not([container]):not([open="true"]) > .toolbarbutton-text { display: none !important; } #PlacesToolbarItems > .bookmark-item:not([container]):not([open="true"]) > .toolbarbutton-icon[label]:not([label=""]) { margin-inline-end: 0px !important; } /* No text on toolbar bookmarks; No text on bookmark folders. Show bookmark text on hover. */ /* #PlacesToolbarItems > .bookmark-item:not(:hover):not([open="true"]) > .toolbarbutton-text { display: none !important; } #PlacesToolbarItems > .bookmark-item:not(:hover):not([open="true"]) > .toolbarbutton-icon[label]:not([label=""]) { margin-inline-end: 0px !important; } */ /* No text on toolbar bookmarks; Text on bookmark folders. Show bookmark text on hover. */ /* #PlacesToolbarItems > .bookmark-item:not(:hover):not([container]):not([open="true"]) > .toolbarbutton-text { display: none !important; } #PlacesToolbarItems > .bookmark-item:not(:hover):not([container]):not([open="true"]) > .toolbarbutton-icon[label]:not([label=""]) { margin-inline-end: 0px !important; } */ ********************************************************************** does anyone have a workaround or a similar add on? i would like to have my booksmarks as shown in the screenshot on my win 11 pc as well.
Attached screenshots

Chosen solution

Apologies, i was dumb and forgot to to turn "toolkit.legacyUserProfileCustomizations.stylesheets" on on the new machine. i would like to close this question. not sure how though, issue is resolved.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Apologies, i was dumb and forgot to to turn "toolkit.legacyUserProfileCustomizations.stylesheets" on on the new machine. i would like to close this question. not sure how though, issue is resolved.