Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox permanently mutes my video on my business site - WHY?!

  • 5 replies
  • 0 have this problem
  • 17 views
  • Last reply by zeroknight

more options

My business site - www.ninjanezumiproductions.com - has videos on it.

Firefox PERMANENTLY MUTES those videos.

I can play them, but I get no sound.

I can play these videos on Chrome, Edge, Opera - etc... and still mute and unmute as normal.

However, when I try to UNMUTE on firefox, it prevents me.

This is harming my business.

I want to know how to fix this.

Sincerely,

Kevin Conner CEO: NNP, LLC

My business site - www.ninjanezumiproductions.com - has videos on it. Firefox PERMANENTLY MUTES those videos. I can play them, but I get no sound. I can play these videos on Chrome, Edge, Opera - etc... and still mute and unmute as normal. However, when I try to UNMUTE on firefox, it prevents me. This is harming my business. I want to know how to fix this. Sincerely, Kevin Conner CEO: NNP, LLC

All Replies (5)

more options

The audio format appears to be AC3 which is not a web standard and does not work in Chromium either: https://www.chromium.org/audio-video/

Try using a different audio codec that will play in all browsers: https://developer.mozilla.org/en-US/docs/Web/Media/Formats/Audio_codecs

more options

Best is probably to use AAC for audio.

more options

My audio codec is AAC not AC3. I have no idea why you think it's AC3.

However, I will recode in dolby digital just in case.

So yeah, I'm 90% certain you lied about it being AC3.

Modified by ninjanezumiproductions

more options

Screenshot from VLC. trailer_punch_hitler.mp4

more options

Both VLC and ffmpeg identify it as AC3.