Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I access a particular website and choose options within that website, the page does not go to the selection until I manually "Refresh" the page by clicking on to the circular arrow symbol.

  • 2 replies
  • 0 have this problem
  • 19 views
  • Last reply by cor-el

more options

It may be the website itself, but I need to manually refresh the page when I choose to go to any other option, shown on the page, is chosen. That is, is this a particular selection in the settings of Firefox?

It may be the website itself, but I need to manually refresh the page when I choose to go to any other option, shown on the page, is chosen. That is, is this a particular selection in the settings of Firefox?

All Replies (2)

more options

Hello,

Thank you for reaching out to the Firefox Support Forum. I understand that you are encountering an issue where a webpage doesn't update or refresh automatically when you select options within the site. I'll be glad to assist you with this.

This behavior might be specific to the website you are visiting, as some websites require manual refreshing to display the updated content. However, there are a few troubleshooting steps we can try to determine if the issue is related to your Firefox settings.

Clear your browser cache: Sometimes, cached data can cause issues with webpage updates. You can clear the cache by following these steps:

Click on the Menu button (three horizontal lines) in the top-right corner of Firefox. Select "Options" (or "Preferences" on macOS) and go to the "Privacy & Security" tab. Scroll down to the "Cookies and Site Data" section and click on "Clear Data..." Make sure "Cached Web Content" is selected and click "Clear." Disable browser extensions: Certain extensions or add-ons can interfere with webpage functionality. You can try disabling them temporarily to see if the issue persists. To disable extensions, go to the Firefox menu, select "Add-ons," and then click on the "Extensions" tab. Disable any enabled extensions and restart Firefox.

Reset Firefox settings: If the above steps don't resolve the issue, you can try resetting Firefox to its default settings. This will remove your customizations and restore Firefox to its original state. To reset Firefox, follow these steps:

Click on the Menu button and select "Help" (or "?" on macOS). Choose "Troubleshooting Information." In the new tab, click on the "Refresh Firefox" button. Please note that resetting Firefox will remove your bookmarks, saved passwords, and some settings. You can choose to back up your important data before proceeding.

If none of these steps resolve the issue, it is likely a specific behavior of the website itself. You may want to reach out to the website's support or contact the website administrator for further assistance.

I hope this helps! Let me know if you have any further questions or if the issue persists after trying these steps.

Best regards, Firefox Support Volunteer

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window