Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Menus and url bar are in tiny mouse print. I've adjusted settings and the pages are fine. How can I increase the font size in those 2 areas?

more options

Since changing to a new monitor and running at 1440p, the menus and url bar are in tiny mouse print. The searching I've done so far seems to point to an update removing user control to change the font size on those items. I've adjusted settings and the pages are fine, but the two things I mentioned are almost unreadable. How can I increase the font size there?

Since changing to a new monitor and running at 1440p, the menus and url bar are in tiny mouse print. The searching I've done so far seems to point to an update removing user control to change the font size on those items. I've adjusted settings and the pages are fine, but the two things I mentioned are almost unreadable. How can I increase the font size there?
Attached screenshots

All Replies (6)

more options

Did you make sure the GPU or IGC video was set to the correct resolution when this was done because this wasn't mention calibrating the GPU/ICU chipset.

Helpful?

more options

Unfortunately, Firefox never had a user option to set font sizes on the toolbar area.

If your display high a high horizontal resolution (for example, 3200 × 1440), I think historically users have had scaling issues but I haven't seen one of those threads for a while.

On your screen, what seems notable is that the text did not scale with the buttons. So my first question is why they are not proportional? Could you take a look at this hidden setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste os-zoom and pause while the list is filtered.

Firefox should display a single preference named browser.display.os-zoom-behavior with a value of 1. These are the valid values:

  • 0 => Ignore the OS-level scaling
  • 1 => Apply OS-level scaling as proportional zoom [default in Firefox 103+]
  • 2 => Apply OS-level scaling as text-only zoom

(3) If your Firefox has a modified value, use the Reset button (left-arching arrow at the right end of the row) to try the default value.

(4) On the other hand, if the default value isn't helping, double-click the browser.display.os-zoom-behavior preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change. Does that improve things? Make them worse? What about 2 -- does that shrink everything further? Remember the reset button if needed.

My goal here is to get text and buttons/tabs proportional again, and then we can move on to methods to scale them up.

Helpful?

more options

You can look at this thread:

  • /questions/1384204 SINCE THE LAST UPDATE, THE FIREFOX SCREEN DOES NOT FIT MY SYSTEM SETTING(125%)

If setting browser.display.os-zoom-behavior = 0 doesn't work for you then you can create a new Number pref on the about:config page and set its value to 100.

Paste ui.textScaleFactor in the search bar and select the Number radio button and click the '+' button to add the new Number pref, enter the value (100) and click the blue OK button to confirm.

  • about:config => ui.textScaleFactor = 100

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

Helpful?

more options

The new monitor has a native resolution of 2560x1440 and that's what the GPU (Nvidia GTX1080TI FTW) is set to, as is the display setting in Windows.

Thanks for all the suggestions and I appreciate them all. I tried all of them but strangely none of them did anything at all to the areas with tiny print. I was previously on Win 7 Pro and am new to Win 10. As for the Windows font control, I do not have a slider but only a series of options. The first one is for 125% which makes a page itself much too large - I have to scroll in multiple directions just to see the first item on the page.

Helpful?

more options

To counteract the increased page content zoom, you can adjust the Default Zoom control on the Settings page to 80% (80% x 125% => 100%).

Helpful?

more options

If you don't want to use 125% at the system level, you can set Firefox to use 125% as its global zoom factor. Here's how, but I suggest starting with 150%:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the filter box, type or paste devp and pause while the list is filtered. Firefox should show a single preference with a value of -1.

(3) Double-click layout.css.devPixelsPerPx preference to display an editing field, and carefully change its value to 1.5 [corresponds to 150%] then press Enter or click the blue check mark button to save the change.

Helpful? Need larger? Smaller? Be careful not to enter too high a value or Firefox may become impossible to use.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.