Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Internal Links on Webpage Disabled but work in Troubleshooting Mode

  • 4 replies
  • 0 have this problem
  • 15 views
  • Last reply by zkraft79

more options

A website I use regularly has internal links that no longer work in regular mode. They used to work and still work in Troubleshooting Mode.

These links are imperative to using the webpage. I'm not sure what changed or why they work in troubleshoot mode, but I need to fix this right away. They also work on other browsers.

A website I use regularly has internal links that no longer work in regular mode. They used to work and still work in Troubleshooting Mode. These links are imperative to using the webpage. I'm not sure what changed or why they work in troubleshoot mode, but I need to fix this right away. They also work on other browsers.
Attached screenshots

Chosen solution

If it works in Troubleshoot Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Read this answer in context 👍 1

All Replies (4)

more options

Normally these internal links will trigger Firefox to modify the address in the address bar. Are you seeing that, or does Firefox seem to be ignoring the click completely?

When Troubleshoot Mode works normally, our attention usually turns first to add-ons. Thank you for sharing your Add-ons list. The only one that seems relevant to non-Facebook links is the McAfee one. Does it modify links, or remove parameters from links perhaps as an "anti-tracking" feature?

Helpful?

more options

The initial link (ie: Price a Loan) triggers a drop down with select-able options (ie: Easy Qualifier). Once you select one of those options, then the address changes and Firefox navigates to that page.

As of right now, it seems to be ignoring it. The only thing that changes is an up arrow shows up once you click the initial link (Price a Loan). Images attached. It seems like Firefox knows there should be a drop down, but it's not able to show it. It does show up in Troubleshoot Mode.

As far as McAfee, I disabled the Addon and still am having the same problem.

Helpful?

more options

Chosen Solution

If it works in Troubleshoot Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

Helpful?

more options

The Facebook Extension was the culprit! I don't even remember installing it! Thank you cor-el!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.