Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox forces HTTPS for web sites, even if this option is disabled in settings

  • 3 replies
  • 0 have this problem
  • 17 views
  • Last reply by cor-el

more options

Installed version: 104.0.1 (64-bit) on Windows 10, current as of this instant date.

Ref: This question was asked previously at [https://support.mozilla.org/en-US/que.../1341115] about a year ago with no replies or answers.

Issue: I am attempting to access a flight-sim site, http://forum.ivao.aero, and due to the way the site is set up, they refuse to accept https connections. (I know, stupid, but don't bark at me about it. . .)

My problem is that, in settings, I have the preference for enforcing https turned off - yet no matter what I try, it ALWAYS converts it to a HTTPS request.

Trying the same site in Chrome works as expected - though Chrome does get a bit fussy - however, once you reassure it that you haven't lost your mind, it lets you view the site. . . (wink!)

Firefox, on the other hand absolutely REFUSES to allow HTTP requests, which is fatal. Not only for this, but for certain things I do with in-house robotics experiments that are http by default and won't change any time soon.

How do I fix this? Is it even POSSIBLE to fix, or is Mozilla going to assume that everyone is using https and everyone else can go pound sand?

Installed version: 104.0.1 (64-bit) on Windows 10, current as of this instant date. Ref: This question was asked previously at [[https://support.mozilla.org/en-US/questions/1341115]] about a year ago with no replies or answers. Issue: I am attempting to access a flight-sim site, http://forum.ivao.aero, and due to the way the site is set up, they refuse to accept https connections. (I know, stupid, but don't bark at '''''me''''' about it. . .) My problem is that, in settings, I have the preference for enforcing https turned off - yet no matter what I try, it '''''ALWAYS''''' converts it to a HTTPS request. Trying the same site in Chrome works as expected - though Chrome does get a bit fussy - however, once you reassure it that you haven't lost your mind, it lets you view the site. . . (wink!) Firefox, on the other hand absolutely REFUSES to allow HTTP requests, which is fatal. Not only for this, but for certain things I do with in-house robotics experiments that are http by default and won't change any time soon. How do I fix this? Is it even '''''POSSIBLE''''' to fix, or is Mozilla going to assume that everyone is using https and everyone else can go pound sand?

All Replies (3)

more options

Is this an address bar suggestion problem -- it autocompletes to HTTPS in the address bar, but you can visit using HTTP if you use the link in your question or a bookmark or a Google search result?

Assuming it's not just the address bar:

When I use the link in your post, I get a page from Cloudflare checking something and then I get forwarded to the site -- with HTTP, not HTTPS. What is the difference? It's possible that for some reason your Firefox has saved the HTTPS address and wants to re-use it.

Some sites will instruct Firefox never to use HTTP. In that case, the connection error page will usually mention that, perhaps referring to the technical phrase "strict transport security." Do you see anything like that mentioned on the page? If you see an "Advanced" button, you may need to use that to view the technical details. (You can copy/paste into a reply.)

If it's not that, try clearing Firefox's web cache, in case a forced redirect is cached in there. This article has the steps: How to clear the Firefox cache.

Any progress so far?

Helpful?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.