On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cursor dissapears when i press space or `

  • 6 replies
  • 1 has this problem
  • 2 views
  • Last reply by gambit1

more options

Whenever I press space to scroll one page down the cursor dissapears. The same thing happens when I press `. As soon as I move the mouse it reappears but this is unwanted and annoying behavior which didn't happen in the past. I'm not sure when it started happening but it hasn't been long since that. I tried restarting with all the plugins turned off but that didn't help. I'm using the latest version of FF on Win 7 x64.`

Whenever I press space to scroll one page down the cursor dissapears. The same thing happens when I press `. As soon as I move the mouse it reappears but this is unwanted and annoying behavior which didn't happen in the past. I'm not sure when it started happening but it hasn't been long since that. I tried restarting with all the plugins turned off but that didn't help. I'm using the latest version of FF on Win 7 x64.`

Chosen solution

You can look at this pref on the about:config page.

  • about:config => widget.windows.hide_cursor_when_typing => false

You can open the about:config page via the location/address bar. Clear cookies the button to "Accept the Risk and Continue".

WARNING: modifying prefs directly via the about:config page can sometimes break Firefox or cause strange behavior, and there is no guarantee that this will keep working in future Firefox releases, so be cautious with modifying prefs if you aren't sure you understand their purpose.

Read this answer in context 👍 1

All Replies (6)

more options

You may have switched on caret browsing. You can toggle caret browsing off/on by pressing F7 (Mac: fn + F7).

  • Settings -> General: Browsing
    remove checkmark: [ ] "Always use the cursor keys to navigate within pages"

Note that this is a Firefox accessibility feature.

Helpful?

more options

Thanks for your answer but that's not it. That option is off and I've never touched it.

Helpful?

more options

Are you talking about the mouse pointer ?

Helpful?

more options

cor-el said

Are you talking about the mouse pointer ?

Yes, (old habits die hard). I've also noticed it happens when I press backspace too.

Modified by gambit1

Helpful?

more options

Chosen Solution

You can look at this pref on the about:config page.

  • about:config => widget.windows.hide_cursor_when_typing => false

You can open the about:config page via the location/address bar. Clear cookies the button to "Accept the Risk and Continue".

WARNING: modifying prefs directly via the about:config page can sometimes break Firefox or cause strange behavior, and there is no guarantee that this will keep working in future Firefox releases, so be cautious with modifying prefs if you aren't sure you understand their purpose.

Modified by cor-el

Helpful?

more options

Perfect, this fixed it. Thanks. I don't understand why that was changed though. Is it some new default setting in FF? Because I certainly didn't mess with it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.