Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Black screen flashes when running multiple profiles.

  • 1 reply
  • 1 has this problem
  • 8 views
  • Last reply by cor-el

more options

Hi!

I have Firefox 101.0.1 on Windows 10. When I run firefox normally then everything works fine. When I start another firefox with firefox -P and then selec another profile for another instance then my monitors start to flash black. When I close the other instance then it goes away again.

I tried to update my Intel UHD 630 graphics driver from device manager but it already says I have latest driver.

When I ignore that flashing for too long time I will eventually get BSOD. The driver that causes BSOD seems to be igdkmd64.sys.

What is interesting is that it only happens when I run multiple profiles of FF and once with -P option. With single profile at time I can play multiple videos at once and have multiple large images and other stuff open on tabs that put load on system and nothing happens. Even opening multiple windows within same profile with Ctrl + N doesn't cause any problems. But as soon as I load 2 profiles at the same time I get this problem. Any ideas?

Hi! I have Firefox 101.0.1 on Windows 10. When I run firefox normally then everything works fine. When I start another firefox with firefox -P and then selec another profile for another instance then my monitors start to flash black. When I close the other instance then it goes away again. I tried to update my Intel UHD 630 graphics driver from device manager but it already says I have latest driver. When I ignore that flashing for too long time I will eventually get BSOD. The driver that causes BSOD seems to be igdkmd64.sys. What is interesting is that it only happens when I run multiple profiles of FF and once with -P option. With single profile at time I can play multiple videos at once and have multiple large images and other stuff open on tabs that put load on system and nothing happens. Even opening multiple windows within same profile with Ctrl + N doesn't cause any problems. But as soon as I load 2 profiles at the same time I get this problem. Any ideas?

All Replies (1)

more options

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make changes effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.