Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Downloads seem to be blocked randomly, "allow download" button does nothing and downloads are continually blocked on certain sites

  • 2 replies
  • 1 has this problem
  • 7 views
  • Last reply by Terry

more options

Certain sites (the latest being https://azgaar.github.io/Fantasy-Map-Generator/, which i've downloaded successfully from before) cannot be downloaded from - firefox gives the error of "[site] attempted to automatically download multiple files. The site could be broken or trying to store spam files on your device."

I know these downloads aren't spam or malicious, but when I hit the "Allow" button to give permission, there's no change. The downloads remain blocked and new downloads are blocked.

I've turned off my antivirus shields to see if that was causing it, but to no results.

I sincerely thank you for your time and know that you're quite busy, and look forward to hearing back about this issue.

- Jae

Certain sites (the latest being https://azgaar.github.io/Fantasy-Map-Generator/, which i've downloaded successfully from before) cannot be downloaded from - firefox gives the error of "[site] attempted to automatically download multiple files. The site could be broken or trying to store spam files on your device." I know these downloads aren't spam or malicious, but when I hit the "Allow" button to give permission, there's no change. The downloads remain blocked and new downloads are blocked. I've turned off my antivirus shields to see if that was causing it, but to no results. I sincerely thank you for your time and know that you're quite busy, and look forward to hearing back about this issue. - Jae
Attached screenshots

All Replies (2)

more options

I was able to download the map but what are you using to read the map then. No permission pop was shown to me when I did a save as.

Helpful?

more options

The problem could be caused by software (such as security software) or something in your profile (such as an add-on or a setting). A quick way of testing is to create a new profile. Have you possibly set the following preference to true? If so, change it back to false because it stops redirects until you allow them. accessibility.blockautorefresh

https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles

https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems (also deals with hardware acceleration)

You could also try clearing cookies and site data and clearing the cache.

https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Modified by Terry

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.