Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not playing embedded Youtube videos in my phpBB forum

  • 6 replies
  • 1 has this problem
  • 70 views
  • Last reply by FredMcD

more options

Firefox recently stopped playing embedded youtube videos on my phpBB forum site?

i keep the latest firefox and only recently showed up embedded videos play fine on Chrome and others

here's a link to my forum which includes an embedded Youtube video demonstrating the issue, does it play on your browser? (ONLY firefox has an issue on my computer, chrome, etc. work fine)

https://www.mchenrysoftware.com/board/viewtopic.php?t=2045

thanks for any tests/insight into what might be causing the issue

brian

ADDITIONAL COMMENT: why don't you include a date on these posting? a lot of wasted time on old posts? and also need a 'Preview' on these before posting?

'''Firefox recently stopped playing embedded youtube videos on my phpBB forum site?''' i keep the latest firefox and only recently showed up embedded videos play fine on Chrome and others here's a link to my forum which includes an embedded Youtube video demonstrating the issue, does it play on your browser? (ONLY firefox has an issue on my computer, chrome, etc. work fine) https://www.mchenrysoftware.com/board/viewtopic.php?t=2045 thanks for any tests/insight into what might be causing the issue brian ADDITIONAL COMMENT: why don't you include a date on these posting? a lot of wasted time on old posts? and also need a 'Preview' on these before posting?

Chosen solution

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Brian said

found had a gig of junk in cache (thought i had cleared it recently

Type about:preferences#privacy<enter> in the address box. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Read this answer in context 👍 0

All Replies (6)

more options

I have several versions of Firefox and had no problem.


https://support.mozilla.org/en-US/questions/1359657#answer-1463359 and updated to 95.0. . . . I finally found where the plugin "Widevine Content Decryption Module provided by Google Inc." was not updating to the newest version of December 1, 2021. Ver #4.10.2391.0

cor-el; Make sure you have the latest Widevine version. You can toggle DRM off/on to see if that makes Firefox (re)load DRM components.

You can possibly check the XHR requests in the Browser Console if this doesn't work.

more options

first thank you for the ideas checked version of Widevine all ok (see attached) 2nd turning on/off DRM didn't make any difference so opened the browser console...interesting tool! thanks! however... i haven't a clue why it encountered errors (i attach a pic of the error stream) seems to be going round the world to connect to the youtube video??!!

i insert below the text from one of the errors (would have simply attached the text file...but no option) any idea what is happening and why? i'm not using VPN (in event that might be the issue routing through a bad site) thank you for your quick and excellent response

Brian (and i note a preview button for responses...?? wasn't on on first post?!)

here is the data from one of the errors:

XHRGEThttps://rr3---sn-5uaeznrz.c.youtube.com/videoplayback?expire=1649981459&ei=s2NYYumgF6vl4QTciaK4CQ&ip=2600:1700:1851:4340:d1c2:8c59:c47a:d2cb&cp=X19Tamh5b2UtOE1DUE5YTUE6SGtETzBNT2pwTFJVSzJpQ05SLXVaOVctVjJCOWpsU3l3TV9zdDNTdmtxNw&id=o-AEHR1MquYwxCvHaPMkS1ZmPW5WE5z797JPaiL2dCtesv&itag=134&aitags=133,134,135,136,137,160,242,243,244,247,248,278&source=youtube&requiressl=yes&mh=pN&mm=32&mn=sn-5uaeznrz&ms=su&mv=u&mvi=3&pl=52&sc=yes&spc=4ocVC2vluPfNVQHdl5nfoQ5eYanZXrqEfkIDCA1W8g&vprv=1&mime=video/mp4&ns=EFwsyyv7pbGNCh3L-_08a2wG&gir=yes&clen=2708704&otfp=1&dur=77.733&lmt=1648684144006628&mt=1649958924&keepalive=yes&fexp=24001373,24007246&c=WEB_EMBEDDED_PLAYER&txp=6216224&n=_LmmAZtsDNnwQw&sparams=expire,ei,ip,cp,id,aitags,source,requiressl,spc,vprv,mime,ns,gir,clen,otfp,dur,lmt&sig=AOq0QJ8wRAIgSg1A3uhyav3Ajgi0wAXO-cSAYn3xsH73gTmH0hQut40CIAO63fuPkOYvZF_0FKMFsgCEVcqjCO80lVJs5O5qRCPI&lsparams=mh,mm,mn,ms,mv,mvi,pl,sc&lsig=AG3C_xAwRQIhAJMWqdlkZXkfqthBpvuCl4N29kqxeqz86Ms7Y-K1X9oOAiBoEkImqtJ8wtIJpfQHIKuwCHPOEROjJsMvkrforykNfg==&alr=yes&cpn=yZdZdhm8vDrx3TM7&cver=1.20220412.01.00&range=0-135655&rn=1&rbuf=0&pot=GpsBCm7c4woFePJthExN6DbQ7uYIThDhBXI4x6ISt5Ezkj2Hb6_N0Hqc3q8j1FQCWUM8b3WY2PzCvD0YDhCW44KibLFvJRD8oS5RyKYm9o3nxrMMkET5iUnGnChv8hVnEBl9dcAmH12IbDak5FMdh6cNZRIpATwYQQ7DEt27VIzSqbfPOJ-A2Csrzr4aPjCWQ0ZXzNPiyJUihjHquwA= [HTTP/1.1 403 Forbidden 138ms]


GET https://rr3---sn-5uaeznrz.c.youtube.com/videoplayback?expire=1649981459&ei=s2NYYumgF6vl4QTciaK4CQ&ip=2600:1700:1851:4340:d1c2:8c59:c47a:d2cb&cp=X19Tamh5b2UtOE1DUE5YTUE6SGtETzBNT2pwTFJVSzJpQ05SLXVaOVctVjJCOWpsU3l3TV9zdDNTdmtxNw&id=o-AEHR1MquYwxCvHaPMkS1ZmPW5WE5z797JPaiL2dCtesv&itag=134&aitags=133,134,135,136,137,160,242,243,244,247,248,278&source=youtube&requiressl=yes&mh=pN&mm=32&mn=sn-5uaeznrz&ms=su&mv=u&mvi=3&pl=52&sc=yes&spc=4ocVC2vluPfNVQHdl5nfoQ5eYanZXrqEfkIDCA1W8g&vprv=1&mime=video/mp4&ns=EFwsyyv7pbGNCh3L-_08a2wG&gir=yes&clen=2708704&otfp=1&dur=77.733&lmt=1648684144006628&mt=1649958924&keepalive=yes&fexp=24001373,24007246&c=WEB_EMBEDDED_PLAYER&txp=6216224&n=_LmmAZtsDNnwQw&sparams=expire,ei,ip,cp,id,aitags,source,requiressl,spc,vprv,mime,ns,gir,clen,otfp,dur,lmt&sig=AOq0QJ8wRAIgSg1A3uhyav3Ajgi0wAXO-cSAYn3xsH73gTmH0hQut40CIAO63fuPkOYvZF_0FKMFsgCEVcqjCO80lVJs5O5qRCPI&lsparams=mh,mm,mn,ms,mv,mvi,pl,sc&lsig=AG3C_xAwRQIhAJMWqdlkZXkfqthBpvuCl4N29kqxeqz86Ms7Y-K1X9oOAiBoEkImqtJ8wtIJpfQHIKuwCHPOEROjJsMvkrforykNfg==&alr=yes&cpn=yZdZdhm8vDrx3TM7&cver=1.20220412.01.00&range=0-135655&rn=1&rbuf=0&pot=GpsBCm7c4woFePJthExN6DbQ7uYIThDhBXI4x6ISt5Ezkj2Hb6_N0Hqc3q8j1FQCWUM8b3WY2PzCvD0YDhCW44KibLFvJRD8oS5RyKYm9o3nxrMMkET5iUnGnChv8hVnEBl9dcAmH12IbDak5FMdh6cNZRIpATwYQQ7DEt27VIzSqbfPOJ-A2Csrzr4aPjCWQ0ZXzNPiyJUihjHquwA= Status 403 Forbidden VersionHTTP/1.1 Transferred772 B (0 B size) Referrer Policystrict-origin-when-cross-origin


   Access-Control-Allow-Credentials
   	true
   Access-Control-Allow-Origin
   	https://www.youtube.com
   Access-Control-Expose-Headers
   	Client-Protocol, Content-Length, Content-Type, X-Bandwidth-Est, X-Bandwidth-Est2, X-Bandwidth-Est3, X-Bandwidth-App-Limited, X-Bandwidth-Est-App-Limited, X-Bandwidth-Est-Comp, X-Bandwidth-Avg, X-Head-Time-Millis, X-Head-Time-Sec, X-Head-Seqnum, X-Response-Itag, X-Restrict-Formats-Hint, X-Sequence-Num, X-Segment-Lmt, X-Walltime-Ms
   Connection
   	close
   Content-Length
   	0
   Content-Type
   	text/plain
   Date
   	Thu, 14 Apr 2022 18:10:59 GMT
   Last-Modified
   	Wed, 02 May 2007 10:26:10 GMT
   Server
   	gvs 1.0
   Timing-Allow-Origin
   	https://www.youtube.com
   Vary
   	Origin
   X-Content-Type-Options
   	nosniff
   X-Restrict-Formats-Hint
   	None
   	
   Accept
   	*/*
   Accept-Encoding
   	gzip, deflate, br
   Accept-Language
   	en-US,en;q=0.5
   Connection
   	keep-alive
   Cookie
   	VISITOR_INFO1_LIVE=V67SbRitO4Y
   DNT
   	1
   Host
   	rr3---sn-5uaeznrz.c.youtube.com
   Origin
   	https://www.youtube.com
   Referer
   	https://www.youtube.com/
   Sec-Fetch-Dest
   	empty
   Sec-Fetch-Mode
   	cors
   Sec-Fetch-Site
   	same-site
   User-Agent
   	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0
more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

No problems here to see the embedded YouTube video on that forum page.

There is no DRM involved, so Widevine wouldn't matter as this is just a normal video.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click the shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Modified by cor-el

more options

FIXED! thanks to all for the help and suggestions. wasn't any extension (only have Webex) or plugin (only have H264 & Widevine)

BUT found had a gig of junk in cache (thought i had cleared it recently but guess not OR somethign cloggin up the cache) will keep a check on that

Thank all who sent help! best wishes to you all!

more options

Chosen Solution

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Brian said

found had a gig of junk in cache (thought i had cleared it recently

Type about:preferences#privacy<enter> in the address box. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.