Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error message trying to launch "Search by Image", "Content scripts are not allowed on this page."

  • 7 replies
  • 2 have this problem
  • 63 views
  • Last reply by Pfaelzer56

more options

I just installed Add-on "Search by Image" with "Tin Eye". When I try to launch the program I get the Error Message, "Content scripts are not allowed on this page."

How do I correct this so that it works as advertised?

I just installed Add-on "Search by Image" with "Tin Eye". When I try to launch the program I get the Error Message, "Content scripts are not allowed on this page." How do I correct this so that it works as advertised?

Chosen solution

Sorry, I meant what site are you testing on.

Read this answer in context 👍 0

All Replies (7)

more options

If the website disables searches as you mentioned here - there's nothing one can do about it. This would be something you need to report the issue to the Developer of the Addon.

more options

Content scripts are blocked on built-in pages, the PDF viewer, and certain Mozilla sites. However, it should work on normal sites. Where are you testing?

more options

Firefox Browser 98.0.2 (64-bit)

more options

Chosen Solution

Sorry, I meant what site are you testing on.

more options

Hello, I have the same problem with Firefox 98.02, when I push the add on button -> Error message trying to launch "Search by Image", "Content scripts are not allowed on this page."

Is there any bug fix?

Cheeres Claus

more options

Hi Claus, are you using the right-click option (as pictured in the attached screenshot)?

Are you trying to use the script on a restricted page -- that includes several Mozilla sites, built-in pages, and the PDF viewer -- or does this happen on an ordinary page?

more options

Hi jscher, sorry for the delay. I had problem to find the forum and the chat. I expected I get a email when I received an answer. Your are right the problem is mozilla image. With e.g. Wikipedia image it works. Again thanks for your answer. This was my first question in mozilla forum. Claus