Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable download panel automatically opening?

  • 15 replies
  • 4 have this problem
  • 4244 views
  • Last reply by Andrew P

more options

My job requires me to download and open files in new tabs consistently. However, when I download these files, I don't want the download panel to obscure my vision. Can I disable it?

My job requires me to download and open files in new tabs consistently. However, when I download these files, I don't want the download panel to obscure my vision. Can I disable it?

Chosen solution

Enter about:config in the URL bar and set browser.download.alwaysOpenPanel = false.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Read this answer in context 👍 5

All Replies (15)

more options

Does the 'download panel' ask where you want to save/name the file in question? Once that information has been entered and you press Save, the panel should close.

more options

Not exactly. The download panel would be what would come up if you click on the download icon on the top right of your screen. In the latest firefox update they made it so it automatically opens when you download a file.

more options

It would be this thing here in the top right.

more options

<Control> J should open/close that.

more options

Chosen Solution

Enter about:config in the URL bar and set browser.download.alwaysOpenPanel = false.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Modified by Chris Ilias

more options

I'm not trying to open the download library, I'm trying to disable the feature that automatically opens the download panel when I download something. (this was just added in the latest update)

more options

TyDraniu said

Enter about:config in the URL bar and set browser.download.alwaysOpenPanel = false.

How exactly do I enter this? As a string?

EDIT: Never mind, I just have to search for it. Thanks!

Modified by thetitansilva

more options

Type about:config<enter> in the address box. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.download.alwaysOpenPanel

Change it to false.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Modified by Chris Ilias

more options

with all due respect, i would not call this feature annoying. i would call it super-annoying. because it is.

more options

See also this thread with solution: https://support.mozilla.org/en-US/questions/1370262

more options

I'm soooo tired of this "fixing things that are not broken"… Last year it was the adress bar autoselecting in GNU/Linux instead of behaving like any other text area, now this panel showing when we just want to see a PDF inside the browser and files that we ask to open in an app which get saved in Download folder instead of temporarily dumped in /tmp, so we need to actively delete them instead of just forgetting them…

Please, improve things that need improving and stop breaking things that work.

more options

herisson26 said

I'm soooo tired of this "fixing things that are not broken"… Last year it was the adress bar autoselecting in GNU/Linux instead of behaving like any other text area, now this panel showing when we just want to see a PDF inside the browser and files that we ask to open in an app which get saved in Download folder instead of temporarily dumped in /tmp, so we need to actively delete them instead of just forgetting them… Please, improve things that need improving and stop breaking things that work.

I'm struggling with the same bit here. I just want my pdfs to be put in temp so I don't have to delete them later. How is that overlooked when updating your application. The latest update seemed more like a downgrade to me...

more options

TyDraniu said

Enter about:config in the URL bar and set browser.download.alwaysOpenPanel = false. WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect. [Warning added by moderator]

Is there a way to force about:config to load? About:config has never appeared since updating a long time ago, & at the same time that problem started, the Downloads window shows after every download, so i can't use about:congif to check/change the settings... about:about loads fine... tried uninstalling, trying Firefox Nightly...

more options

thetitansilva said

I'm not trying to open the download library, I'm trying to disable the feature that automatically opens the download panel when I download something. (this was just added in the latest update)

The same story irritates me to the top I tried browser.download.alwaysOpenPanel setting it to "false" and not so good things started to happen. Mission was accomplished, I would no more see the annoying drop down menu when downloading something (an indication on the arrow for downloads was enough, like before) But some features started acting strangely, when it was download related, and I set it back on to "true" when I found out on some site some features do not work, like a pop-up button with special functions, when I checked that site with another browser, all was well functional, so that is why I have to stand the annoying drop-down menu when download is initiated and the menu keeps hanging there. Or maybe developers will improve that feature (downgrade :) ... who knows ...

more options

Hey guys you are suck here in MOZILLA never do enough Help. Back to Chrome