Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable the pop-up from a complete download

  • 20 replies
  • 19 have this problem
  • 15773 views
  • Last reply by laureano

more options

Ever since the last update, every time I download something on Firefox this download tab pops up every time when the new download is complete. Ive tried disabling every extension, Ive tried the about:config solution I found on this page, setting it to "false" and I havent been able to find anything in tools or settings.. but nothing disables it and its getting annoying. Ive had Firefox for years and this has never happened before.

Ever since the last update, every time I download something on Firefox this download tab pops up every time when the new download is complete. Ive tried disabling every extension, Ive tried the about:config solution I found on this page, setting it to "false" and I havent been able to find anything in tools or settings.. but nothing disables it and its getting annoying. Ive had Firefox for years and this has never happened before.
Attached screenshots

Chosen solution

In Firefox 97 and 98+ there have been changes to the download panel.

You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 22

All Replies (20)

more options

Chosen Solution

In Firefox 97 and 98+ there have been changes to the download panel.

You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

cor-el said

In Firefox 97 and 98+ there have been changes to the download panel. You can set this pref to false on the about:config page to prevent opening the download panel on each download.
  • browser.download.alwaysOpenPanel = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Thanks, this worked for me!

more options

It's a bug. It just started happening to me the other day, even though I haven't updated Firefox lately.

more options

cor-el said

In Firefox 97 and 98+ there have been changes to the download panel. You can set this pref to false on the about:config page to prevent opening the download panel on each download.
  • browser.download.alwaysOpenPanel = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

How do i get about:config to open? i put it in the address bar, & Enter, but nothing is happening? Using macOS & Firefox 98.0.1

more options

If you type or paste about:config in the location bar and hit the Enter key then you should g the about:config page. If that isn't the case then do other about pages like about:about that shows all available about pages work ?

more options

cor-el said

If you type or paste about:config in the location bar and hit the Enter key then you should g the about:config page. If that isn't the case then do other about pages like about:about that shows all available about pages work ?

ok, about:about loads but clicking the about:config link on the about:about page also doesn't do anything... the other links load though... i will try resetting everything later on & retry it :)

Modified by bigk316

more options

Are there policies active as it is possible to block access to pages like about:config that way ?

You can check the about:policies page (63+) to see if policies are active and if errors are reported.

more options

jos.bonilla said

Ever since the last update, every time I download something on Firefox this download tab pops up every time when the new download is complete. I've tried disabling every extension, I've tried the about:config solution I found on this page, setting it to "false" and I haven't been able to find anything in tools or settings.. but nothing disables it and it's getting annoying. I've had Firefox for years and this has never happened before.

Thanks so much for posting this question, as I was having the same problem and it was driving me crazy too. The solution provided here fixed the problem for me as well.

more options

I like the idea of the download panel appearing at the end of a successful download, just not when nothing is downloading.

I've been experiencing this since one of the recent updates. After I download one item, the panel opens to tell me the download is done, but when I'm done with the panel, it will randomly appear again (repeatedly), until I restart firefox.

This is true on Windows 11, and Kubuntu 20.04. Firefox version is 98.0.1 (64-bit)

more options

I also experience download panel appearing at the end of a successful download (which is ok) and then out-of-the-blue again and again, when nothing is downloading. It is very distracting and confusing, so for now I decided to switch it off completly. I am using Linux, Fedora 36 to be exact.

Is there a way to make it appear just one time after successful download and not show up randomly without any reason?

more options

Just downloaded some pictures and almost head an epileptic fit.

cor-el said

In Firefox 97 and 98+ there have been changes to the download panel.

wait this was done deliberately? who came up with this and thought it is a good idea? It would be nice if you guys dont fuck up the only non-chromium based browser even more.

Modified by randomnumber48499

more options

I don't want to disable it completely. I just want it to stop appearing in my face every minute, or few, after the first (or only) download is done.

I doubt this annoyance is deliberate. I'm going to assume it is a bug that slipped by QA testing, because Mozilla is usually pretty good.

more options

Such an awful "feature", good thing it can be turned off, but I imagine it will annoy the hell out of casual users.

more options

i cant turn it off. So bad.

more options

This "feature" is why I'm still on 97.0.2. Maybe I'll update and try the fix eventually. And, of course, when I downgraded (upgraded?) it "conveniently" couldn't keep my profile info, despite nothing having changed and only being a very minor downgrade, and of course there was no issue using it from 97 to 98. So I had to jump through a bunch of hoops just to get it to stop doing this annoying behavior. When changes like this are made, it needs to be made very clear how to adjust it. Doing stuff like that is driving people away, not bringing them in.

Modified by vertigo220

more options

I agree with vertigo220. Absolutely annoying that the behaviour just changes from one version to next without any notice. Even worse that there's no way to change this in settings. Instead, I now have to remember some cryptic about:config option and adjust it (which, as Firefox reminds me, is a risk for both performance and security) for multiple Firefox installations. I hate it.

more options

FWIW, here's another dissatisfied user wondering who conceived of this, who approved it, and why there isn't a toggle for it in the right-click popup of the download toolbar entry (defaulting to OFF, of course, because nobody but a mother can love a UI widget which continually gets in the way). It's not only a tremendous annoyance which needs to be removed or made easier to disable, but it hinders use of certain web pages. e.g. in Google Photos, when individually selecting and downloading multiple images, this popup keeps blocking my access to the image i'd like to select for download, forcing me to click it out of the way between every image before doing what i'm trying to do.

Modified by Stephan Beal

more options

cor-el said

In Firefox 97 and 98+ there have been changes to the download panel. You can set this pref to false on the about:config page to prevent opening the download panel on each download.

I've been having this same Download problem, but i enter "about:config" & press enter, & nothing happens. Might have been since the last update when the Downloads popup issue started (not sure).

Tried reinstalling & also using Firefox Nightly. Same problems with Firefox & Firefox Nightly.

Is there a way to force about:config to load/appear? or downgrade Firefox?

also, one interesting thing: If i save anything from www.instagram.com, the Downloads window does not appear, & the downloads don't show in the Downloads window!

Modified by bigk316

more options

cor-el said

If you type or paste about:config in the location bar and hit the Enter key then you should g the about:config page. If that isn't the case then do other about pages like about:about that shows all available about pages work ?
Are there policies active as it is possible to block access to pages like about:config that way ? You can check the about:policies page (63+) to see if policies are active and if errors are reported.

About:config still not loading; about:about loads, About: policies says: "& The Enterprise Policies service is inactive." on its page

Modified by bigk316

more options

This "feature" is a total failure and should of course not be enabled by default. it is annoying, it is an obstacle that interferes with the workflow. If there is a need for such a thing (to have the downloads list automatically available for click), the chrome solution (the bottom downloads banner or whatever it is called) is better. Copy that, there is no shame in that. Or is it copyrighted or something?