Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webpage not displaying in chose language.

  • 3 replies
  • 1 has this problem
  • 2 views
  • Last reply by Wkimby

more options

I am having a problem with Firefox displaying my home page, yahoo.com in English. I defaults to espanol. Cannot find a solution to this as I have tried most everything suggested, clean cache, website links. reset through troubleshooting, resetting modem, pc and router. This is pretty much a webpage problem and all links from that page. I do not have this issue with independent links from bookmarks. Or other Browsers like Chrome of IE. I use yahoo as my main Productivity center and would like your help fixing this issue.

I am having a problem with Firefox displaying my home page, yahoo.com in English. I defaults to espanol. Cannot find a solution to this as I have tried most everything suggested, clean cache, website links. reset through troubleshooting, resetting modem, pc and router. This is pretty much a webpage problem and all links from that page. I do not have this issue with independent links from bookmarks. Or other Browsers like Chrome of IE. I use yahoo as my main Productivity center and would like your help fixing this issue.

All Replies (3)

more options

Other relevant information: I have been using Firefox for sometime now, over years. I have several PC on a home network and they all have this same issue. Have been running a VPN for the last Year with Firefox and did not have any problems until today. My Pc's on the Network have different versions of windows, Win10 and Win7 Pro.

Problem seems to be isolated to yahoo.com, so maybe i inadvertently changed a setting for this website. Though that wouldn't explain why I have the issue on a different computer

more options

There is a button at the top of the page (if you are logged in, at least) labelled with your name. You can use that to get Settings then Preferences which contain a language selection.

more options

The Language selected is English (us). This has not reset the webpage. After restarting firefox and going to yahoo.com, I end up at Espanol.yahoo.com.