Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox only opens a blank white screen

  • 2 replies
  • 5 have this problem
  • 2038 views
  • Last reply by James

more options

For the last few days Firefox has been having loading problems. Most of the time (95%) Firefox only opens a white screen. I do not get the Pocket Home Page, if I type a URL in it simply tries to load it but nothing ever loads. If I try to type in "about:profiles" nothing happens. Occasionally a link will load. Although then if I try navigating else where it doesn't load. Firefox is up to date, that was the first thing I checked. I refreshed Firefox yesterday and that seemed to work, although today it was back to not loading. I uninstalled and reinstalled today. I tried refreshing after installing, setting up a new profile and nothing works. I can navigate the web on Chrome and get e-mail through Outlook just fine. I've scanned my computer with Webroot and found nothing. I can not get anything to load from navigating with navigation bar. I tried typing in "about:support" and it didn't load. I can go to the Help menu and select "more troubleshooting options" and then The Troubleshooting info loads.

Can anybody help me figure this mystery out?

For the last few days Firefox has been having loading problems. Most of the time (95%) Firefox only opens a white screen. I do not get the Pocket Home Page, if I type a URL in it simply tries to load it but nothing ever loads. If I try to type in "about:profiles" nothing happens. Occasionally a link will load. Although then if I try navigating else where it doesn't load. Firefox is up to date, that was the first thing I checked. I refreshed Firefox yesterday and that seemed to work, although today it was back to not loading. I uninstalled and reinstalled today. I tried refreshing after installing, setting up a new profile and nothing works. I can navigate the web on Chrome and get e-mail through Outlook just fine. I've scanned my computer with Webroot and found nothing. I can not get anything to load from navigating with navigation bar. I tried typing in "about:support" and it didn't load. I can go to the Help menu and select "more troubleshooting options" and then The Troubleshooting info loads. Can anybody help me figure this mystery out?

Chosen solution

https://www.mozilla.org/firefox/97.0.1/releasenotes/

Fixed Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations

Read this answer in context 👍 0

All Replies (2)

more options

Oh, ya. I'm using Firefox version 97.0 and Windows 10 Home. Computer security is Webroot.

more options

Chosen Solution

https://www.mozilla.org/firefox/97.0.1/releasenotes/

Fixed Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations