Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable new-downloads dropdown menu.

  • 3 replies
  • 2 have this problem
  • 131 views
  • Last reply by gtsavdar

more options

In the latest Firefox update a very annoying new "feature" arrived. When you download something, an automatic drop down menu appears in the top toolbar and stays there until the file is being downloaded and closed after some seconds after the download is finished. You can click of course somewhere to make it vanish.

This is TOO ANNOYING. It also covers a portion of the main page. How can i disable this behavior and return to the old one where nothing appears automatically?

In the latest Firefox update a very annoying new "feature" arrived. When you download something, an automatic drop down menu appears in the top toolbar and stays there until the file is being downloaded and closed after some seconds after the download is finished. You can click of course somewhere to make it vanish. This is TOO ANNOYING. It also covers a portion of the main page. How can i disable this behavior and return to the old one where nothing appears automatically?

Chosen solution

Just enter about:config in the URL bar and set browser.download.alwaysOpenPanel = false.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Just enter about:config in the URL bar and set browser.download.alwaysOpenPanel = false.

more options

Can you show the issue. This is all I get in Win11 downloading a .iso (4.0 GiB). The 2nd screenshot is what I get when I click the download icon.

more options

TyDraniu said

Just enter about:config in the URL bar and set browser.download.alwaysOpenPanel = false.

That did the trick, many thanks!


jonzn4SUSE said

Can you show the issue. This is all I get in Win11 downloading a .iso (4.0 GiB). The 2nd screenshot is what I get when I click the download icon.

I always got that menu in the 2nd screenshot when a download started(and not just when i clicked on it) but the above setting stopped that behavior.