Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Printing - turn off Firefox print dialog in Firefox 97

more options

Firefox 97 installed itself , and now I have two print dialogs each time I go to print something. I have the system print dialog , and the Firefox print dialog. Does anyone one know a way to turn of the Firefox dialog in 97?

I fixed it in earlier versions by setting

print.tab_modal.enabled = false

...but in Firefox 97 it seems this no longer does the job.

Grateful for any advice.

Firefox 97 installed itself , and now I have two print dialogs each time I go to print something. I have the system print dialog , and the Firefox print dialog. Does anyone one know a way to turn of the Firefox dialog in 97? I fixed it in earlier versions by setting print.tab_modal.enabled = false ...but in Firefox 97 it seems this no longer does the job. Grateful for any advice.

All Replies (17)

more options

I rely on the Mac print preview to select pages to print. Especially in large documents. setting the print.tab_modal.enabled to False was quick and easy. I had one click print preview. Now I have to jump thru hoops -- file/print/ scroll down/ click use system dialoge/ ---- restore the option to by pass this. It is inconvenient and a huge waste of time. And NO the save PDF option is not an option. That adds even more steps to save a document to the HD that now have to go back in a delete!!!!

Helpful?

more options

colinhayes007 said

Firefox 97 installed itself , and now I have two print dialogs each time I go to print something. I have the system print dialog , and the Firefox print dialog.

When you call up print, you should get Firefox's combined preview/setup/print overlay and not two different dialogs.

Why do you need to use the system dialog?

Helpful?

more options

The system print dialog opens , and then the Firefox print preview screen. I only need the system print screen.

I'm not disposed to disabling the system print dialog , and this would have effects across the whole machine.

Before 97 the Firefox preview screen could be disabled. Now it seems it's compulsory , and adds several more key presses for each and every print..

Helpful?

more options

colinhayes007 said

The system print dialog opens , and then the Firefox print preview screen.

How are you calling up print? You definitely should not get two dialogs.

Helpful?

more options

Well , this has happened on pretty much every page I've opted to print so far in 97 , either by dedicated 'print' button on the page or via left click -> print.

It seems that they changed the print facilities so that the Firefox preview screen runs as well as the system print dialog. Before 97 this didn't happen.

A simple radio button in the settings UI would a nice thing for those who don't want to use the Firefox print dialog.

Maybe somebody will find a work-around or develop an app to offer this choice to the user.

Modified by colinhayes007

Helpful?

more options

colinhayes007 said

Well , this has happened on pretty much every page I've opted to print so far in 97 , either by dedicated 'print' button on the page or via left click -> print.

A Print button in a page usually runs the window.print() script command, and that triggers the combined preview/setup/print overlay. Is it a website-specific button, or an add-on button?

I'm used to calling up Print by using Ctrl+P on Firefox for Windows. Do you get two dialogs that way, or clicking Print on the main menu?

I don't think Firefox has a right-click > Print option; maybe that is an add-on feature?

Helpful?

more options

Thanks for your help. I'm not really trying to re-structure all of my usual routines in Firefox to accommodate its recent changes. I'm really looking to carry on much as I was before , as I think are many who've raised this issue since it began a few days ago.

Modified by colinhayes007

Helpful?

more options

I don't know what is going on in your Firefox, sorry. You should not get two dialogs, you should only get the new combined overlay. There are no options to get two dialogs, and no options to turn off the combined overlay. There are bugs on file to add more options in a future release, but that's unlikely to happen during the next four weeks.

Helpful?

more options

I'm grateful for your support. I was very happy with just the system print dialog. There was a way around the Firefox dialog before 97 by setting print.tab_modal.enabled to False. This was fine.

Now the Firefox print dialog is apparently compulsory , and I'd would much rather it wasn't. That's the extent of my query.

I don't know what the problem with the previous arrangement was , or why the devs decided it reduce the options in the program.

Hopefully somebody clever will make an app to get around it. I don't hold out much hope that Firefox will be changing it back.

Helpful?

more options

As a further problem with Firefox's removal of the ability to default to the windows system print dialogue in W7 and being forced to use the 'new' Print UI, I am unable, as far as I can see, to print a selection on the page without clicking on to the system dialogue link at the bottom of the Print UI window and going to the system print function anyway and then selecting "Print Selection".

Firefox need to restore the default print.tab_modal.enabled pref so the system print dialogue can remain the Firefox default and bypass the built-in Print UI. What is the point of a print function such as the Print UI that is not completely functional, with ease?

Helpful?

more options

kemiles said

As a further problem with Firefox's removal of the ability to default to the windows system print dialogue in W7 and being forced to use the 'new' Print UI, I am unable, as far as I can see, to print a selection on the page without clicking on to the system dialogue link at the bottom of the Print UI window and going to the system print function anyway and then selecting "Print Selection".

Please refer to my reply in your thread: https://support.mozilla.org/en-US/questions/1367391#answer-1482939

Helpful?

more options

Why not just leave the print routine as it was?

All of this back-and-forth for an issue that was fine as it was.....

Just reinstate it with the work around in place.

Helpful?

more options

There is a bug on file to create a user option to bypass the preview.

There was a long feedback period for this change, from Firefox 84 to Firefox 96, before the old code was ripped out. I wish more people had been giving feedback during that time so everything could have been resolved, but as they say, we are where we are.

Helpful?

more options

jscher2000 сказав(-ла)

There is a bug on file to create a user option to bypass the preview.

Please provide a bug number or a link to the bug, so we can go and show our support for this feature.

There was a long feedback period for this change, from Firefox 84 to Firefox 96, before the old code was ripped out. I wish more people had been giving feedback during that time so everything could have been resolved, but as they say, we are where we are.

Well, not all people follow the development details about what will be dropped. They don't know until it suddenly doesn't work. We are where we are.

Helpful?

more options

I've no idea why Firefox needs to force it's lame print dialogue box on me. And to offer no option to disable means they've really just become everything they initially said they weren't. So they're not the browser for me any more. Sorry Firefox, you really overstepped my boundaries.

Helpful?

more options

There are now several posts about this on the new feedback site connect.mozilla.org (which has replaced mozilla.crowdicity.com). You can access this new site using your Firefox login. I would encourage anyone who has an opinion about this to visit the new site and leave some feedback.

Helpful?

more options

=== For those who do not want any preview ===

It's finally here. Firefox 101 has a preference to bypass the combined print preview/setup overlay and go straight to the system dialog. Here's how you can try it out:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste print.prefer_system_dialog and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

If you need to restore the default display, you can call up the preference and double-click again to toggle the value back to false. There's also will be a reset arrow at the right end of the row when the preference has a non-default value.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.