Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Startup configuration

  • 1 reply
  • 1 has this problem
  • 3 views
  • Last reply by FredMcD

more options

Just in the last week or so, Firefox has started reopening previous pages on startup. I DO NOT have that option checked in Settings. Is this a bug in the latest version? Is there some other setting I need to change so that Firefox will open on my designated home page (as it always has in the past)?

Just in the last week or so, Firefox has started reopening previous pages on startup. I DO NOT have that option checked in Settings. Is this a bug in the latest version? Is there some other setting I need to change so that Firefox will open on my designated home page (as it always has in the past)?

All Replies (1)

more options

If the browser crashed or did not close properlly, it will restore the last session. This is how the browser is set up.

Make sure you close the browser using; Windows: Menu > File > Exit Mac: Menu > Firefox > Quit Firefox Linux: Menu > File > Quit


You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html


Type about:support<enter> in the address box.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.