Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube doesn't show videos, comments, playlists etc.

  • 4 replies
  • 1 has this problem
  • 31 views
  • Last reply by jonzn4SUSE

more options

Since a few hours, Youtube hasn't shown videos, comments, recommendations. It doesn't show any videos when I click on "abos". It only shows white space were the videos should be. If I type in a keyword in the search bar only white space is the result. The only way I can access videos is from the start page. There, recommendations are visible, and I can click on them and watch the videos. However, comments are still invisible, and the playlist space and the recommendations space to the right are also empty.

What I have alredy tried:

Firefox is updated, plug-ins are all up-to-date, and I have emptied my cache and deleted cookies. I've signed off YouTube and on again. I disabled adanced tracking protection. I tried opening YouTube in a private window. Nothing changed. Internet Explorer shows YouTube as it should, as does Firefox on my mobile phone. What can I do?

Chosen solution

Hello Anna, What security software are you running? Have you updated to 95.0.2? Have you tried Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Can you post a similar screenshot showing the issue? see screenshot

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

Hello Anna, What security software are you running? Have you updated to 95.0.2? Have you tried Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Can you post a similar screenshot showing the issue? see screenshot

Helpful?

more options

Thank you for the quick reply - you helped me solve the problem! THANK you!!!

In case someone with the same problem reads this, here is what solved the problem:

Opening YouTube in Troubleshooting mode showed that with all add-ons disabled YouTube worked. So I then opened YouTube in normal mode and disabled each add-on by hand, one after the other, refreshing the page each time in order to find out which add-on was causing the issue. It was Video Blocker - an add-on that is supposed to only block specific videos and channels and which I'd had enabled for years with no problems. But now, as soon as I disable Video Blocker, the issue is solved. Videos und comments and playlists are all visible again. When I enable Video Blocker, they are gone. So I removed that add-on. And everything is as it should be.

PS: I apologise for the double post; for some reason at first when I tried to edit the post it posted a reply to my post instead of editing it... I tried to delete the "reply" but didn't find an option to do that.

Modified by anna.klaffinger

Helpful?

more options

Sorry, never intended to "answer" to myself, but it doesn't let me delete it!

Modified by anna.klaffinger

Helpful?

more options

Good job.  ;-))

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.