Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browsec Extension Disappeared from Toolbar

  • 1 reply
  • 1 has this problem
  • 24 views
  • Last reply by cor-el

more options

For the last year, I have enjoyed using the Browsec extension. It shows as an installed extension in my Firefox browser, but the icon has disappeared from my toolbar and i can't find a way to run it. How can I run Browsec now? I'm using Firefox 95.0.2 (64-bit).

Thanks

Chosen solution

You can check that you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

See also:


Open the Customize window and set what toolbars (Show/Hide Toolbars) and toolbar items to display.

  • check that "Bookmarks Toolbar Items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar Items" is not on the Bookmarks Toolbar then drag it back from the Customize palette to the Customize window to the Bookmarks Toolbar

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

You can check that you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

See also:


Open the Customize window and set what toolbars (Show/Hide Toolbars) and toolbar items to display.

  • check that "Bookmarks Toolbar Items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar Items" is not on the Bookmarks Toolbar then drag it back from the Customize palette to the Customize window to the Bookmarks Toolbar

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.