Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox's omnibox so anti-functional?

  • 9 replies
  • 1 has this problem
  • 45 views
  • Last reply by marshall929

more options

I mean not even mentioning its kind of inferior function to Chrome's omnibox, since I've gotten used to FF ominibox by now-

After deleting cookies & history, the omnibox is not suggesting common websites. I camp on gmail every day for hours. I open gmail.com over and over and over and over and over and over again each day.

A while ago, it would autofill gmail. I deleted cookies & history. Still autofills gmail once I head to gmail a couple of times. Delete history again. No more gmail suggest. Opened like 100 gmail pages, closed them. No autofill.

Why. Please. Just make the omnibox do normal things. Please please

I mean not even mentioning its kind of inferior function to Chrome's omnibox, since I've gotten used to FF ominibox by now- After deleting cookies & history, the omnibox is not suggesting common websites. I camp on gmail every day for hours. I open gmail.com over and over and over and over and over and over again each day. A while ago, it would autofill gmail. I deleted cookies & history. Still autofills gmail once I head to gmail a couple of times. Delete history again. No more gmail suggest. Opened like 100 gmail pages, closed them. No autofill. Why. Please. Just make the omnibox do normal things. Please please

All Replies (9)

more options

Deleting history will of course erase the list of accessed websites from the suggestions box. If you visit gmail so often, why not add it to the Favorites toolbar? Click the empty star near the address bar (if not there they have already moved it somewhere else) and select Bookmarks Toolbar folder, click Done.

Modified by Andrew

Helpful?

more options

I thought about doing that, and then decided to instead ask exactly why the omnibox is so bad.

Helpful?

more options

Instead of clearing everything, try this;

Type about:preferences#privacy<enter> in the address box. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Helpful?

more options

Hi. Tried that but I don't think it has made any difference, sadly.

The omni box is still a piece of dogpoop

Helpful?

more options

You can possibly pin the website to a tile on the Firefox Home page or bookmark the page to be less dependent on history.

Helpful?

more options

Problem is I access multiple inboxes. One through gmail.com and another through gmail.[schooldomain].com. Can't get them to popup on the home page to be pinned.

But I mean. Why is FF's omni box just so anti-functional... I don't even know how to get simple gmail to show up anymore sigh.

Helpful?

more options

You can bookmark webpages or use a keyword (Gmail numbers them: gm0:/u/0/ gm1:/u/1/).

Helpful?

more options

Thanks.

But jesus christ it still didn't work. If you meant keyword by tag it doesn't work.

I mean I appreciate all this help a lot, but like why tf did this work before and not anymore?

Helpful?

more options

So if I type in some keyword, it'll be suggested- But it doesn't get autofilled. This used to happen. No idea what I did wrong by deleting history but i'm sad now.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.